aboutsummaryrefslogtreecommitdiffstats
path: root/stubdom/configure.ac
diff options
context:
space:
mode:
authorChristoph Egger <chegger@amazon.de>2013-05-13 10:24:31 +0200
committerIan Campbell <ian.campbell@citrix.com>2013-05-30 09:07:53 +0100
commit1ecd5e015d67837bb094e9e8921dca4e90578f8a (patch)
treec0f11ff44b0df0a26783745aa72e1f09e5814fc4 /stubdom/configure.ac
parentd21b46e9b723b860ab6e32f6ad96dd4c650596c7 (diff)
downloadxen-1ecd5e015d67837bb094e9e8921dca4e90578f8a.tar.gz
xen-1ecd5e015d67837bb094e9e8921dca4e90578f8a.tar.bz2
xen-1ecd5e015d67837bb094e9e8921dca4e90578f8a.zip
stubdom: Make stubdom buildsystem consistent with tools buildsystem
Use FETCHER for stubdom, too. This makes stubdom buildsystem more consistent with tools buildsystem. Fixes toplevel configure failure if wget is not found independent if we are going to build stubdom or not. Signed-off-by: Christoph Egger <chegger@amazon.de> Reviewed-by: Matt Wilson <msw@amazon.com> Acked-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'stubdom/configure.ac')
-rw-r--r--stubdom/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/stubdom/configure.ac b/stubdom/configure.ac
index de29fb5706..90fc94f591 100644
--- a/stubdom/configure.ac
+++ b/stubdom/configure.ac
@@ -13,6 +13,7 @@ m4_include([../m4/stubdom.m4])
m4_include([../m4/features.m4])
m4_include([../m4/path_or_fail.m4])
m4_include([../m4/depends.m4])
+m4_include([../m4/fetcher.m4])
# Enable/disable stub domains
AX_STUBDOM_DEFAULT_ENABLE([ioemu-stubdom], [ioemu])
@@ -27,13 +28,12 @@ AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of stubdom])
AX_ARG_DEFAULT_ENABLE([extfiles], [Use xen extfiles repository for libraries])
AC_ARG_VAR([CMAKE], [Path to the cmake program])
-AC_ARG_VAR([WGET], [Path to wget program])
+AX_CHECK_FETCHER
# Checks for programs.
AC_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_INSTALL
-AX_PATH_PROG_OR_FAIL([WGET], [wget])
# Checks for programs that depend on a feature
AX_DEPENDS_PATH_PROG([vtpm], [CMAKE], [cmake])