aboutsummaryrefslogtreecommitdiffstats
path: root/docs/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-01-25 09:03:37 +0000
committerIan Campbell <ian.campbell@citrix.com>2013-01-25 09:03:37 +0000
commit9db0ad0f460926d9667dab832663f3d011407024 (patch)
tree8983e2210327ba4460623a72cf16757b63b98fd4 /docs/configure.ac
parent5806093a20e20209d4b88ab866ae1e6017c95de7 (diff)
downloadxen-9db0ad0f460926d9667dab832663f3d011407024.tar.gz
xen-9db0ad0f460926d9667dab832663f3d011407024.tar.bz2
xen-9db0ad0f460926d9667dab832663f3d011407024.zip
docs: check for documentation generation tools in docs/configure.
It is sometimes hard to discover all the optional tools that should be on a system to build all available Xen documentation. By checking for documentation generation tools at ./configure time and displaying a warning, Xen packagers will more easily learn about new optional build dependencies, like markdown, when they are introduced. Based on a patch by Matt Wilson. Changed to use a separate docs/configure which is called from the top-level in the same manner as stubdoms. Rerun autogen.sh and "git add docs/configure" after applying this patch. Signed-off-by: Matt Wilson <msw@amazon.com> Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Matt Wilson <msw@amazon.com> (For the change to introduce docs/configure) Acked-by: Roger Pau Monné <roger.pau@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'docs/configure.ac')
-rw-r--r--docs/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/docs/configure.ac b/docs/configure.ac
new file mode 100644
index 0000000000..ea0552e43d
--- /dev/null
+++ b/docs/configure.ac
@@ -0,0 +1,20 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.67])
+AC_INIT([Xen Hypervisor Documentation], m4_esyscmd([../version.sh ../xen/Makefile]),
+ [xen-devel@lists.xen.org], [xen], [http://www.xen.org/])
+AC_CONFIG_SRCDIR([misc/xen-command-line.markdown])
+AC_CONFIG_FILES([../config/Docs.mk])
+AC_CONFIG_AUX_DIR([../])
+
+# M4 Macro includes
+m4_include([../m4/docs_tool.m4])
+
+AX_DOCS_TOOL_PROG([FIG2DEV], [fig2dev])
+AX_DOCS_TOOL_PROG([POD2MAN], [pod2man])
+AX_DOCS_TOOL_PROG([POD2HTML], [pod2html])
+AX_DOCS_TOOL_PROG([POD2TEXT], [pod2text])
+AX_DOCS_TOOL_PROGS([MARKDOWN], [markdown], [markdown markdown_py])
+
+AC_OUTPUT()