aboutsummaryrefslogtreecommitdiffstats
path: root/docs/configure.ac
diff options
context:
space:
mode:
authorChristoph Egger <chegger@amazon.de>2013-05-10 16:07:44 +0200
committerIan Campbell <ian.campbell@citrix.com>2013-05-13 10:53:37 +0100
commit2569c54743c887ec6fbbba74efe56fb113b933fc (patch)
tree14a1874d288db7944e4ad6e23777d6bd9407f6a2 /docs/configure.ac
parent017610862e55a31a5abb2a7e7da39ad628794e1e (diff)
downloadxen-2569c54743c887ec6fbbba74efe56fb113b933fc.tar.gz
xen-2569c54743c887ec6fbbba74efe56fb113b933fc.tar.bz2
xen-2569c54743c887ec6fbbba74efe56fb113b933fc.zip
docs: make 'gmake dist-docs' work
doc: buildsystem fixes - use correct pathes (make gmake dist-docs from toplevel directory work) - configure detects perl as tools/configure does Signed-off-by: Christoph Egger <chegger@amazon.de> Reviewed-by: Matthew Wilson <msw@amazon.de> Acked-by: Ian Campbell <ian.campbell@citrix.com> [ ijc -- reran autogen.sh ]
Diffstat (limited to 'docs/configure.ac')
-rw-r--r--docs/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/docs/configure.ac b/docs/configure.ac
index ea0552e43d..f0ebf00fa7 100644
--- a/docs/configure.ac
+++ b/docs/configure.ac
@@ -10,6 +10,7 @@ AC_CONFIG_AUX_DIR([../])
# M4 Macro includes
m4_include([../m4/docs_tool.m4])
+m4_include([../m4/path_or_fail.m4])
AX_DOCS_TOOL_PROG([FIG2DEV], [fig2dev])
AX_DOCS_TOOL_PROG([POD2MAN], [pod2man])
@@ -17,4 +18,7 @@ AX_DOCS_TOOL_PROG([POD2HTML], [pod2html])
AX_DOCS_TOOL_PROG([POD2TEXT], [pod2text])
AX_DOCS_TOOL_PROGS([MARKDOWN], [markdown], [markdown markdown_py])
+AC_ARG_VAR([PERL], [Path to Perl parser])
+AX_PATH_PROG_OR_FAIL([PERL], [perl])
+
AC_OUTPUT()