aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <Ian.Campbell@citrix.com>2013-02-05 15:47:41 +0000
committerIan Campbell <Ian.Campbell@citrix.com>2013-02-05 15:47:41 +0000
commitc23ea051ccee613e668b2a87817d49a28215ac8b (patch)
tree5d316c584c26b20054ef891eca735cf5a7de1a17 /configure.ac
parent668635a35e65e9d98618ea0225f56893dde9b6e1 (diff)
downloadxen-c23ea051ccee613e668b2a87817d49a28215ac8b.tar.gz
xen-c23ea051ccee613e668b2a87817d49a28215ac8b.tar.bz2
xen-c23ea051ccee613e668b2a87817d49a28215ac8b.zip
xen: enable stubdom on a per arch basis
... and disable on ARM (for now). Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index df1d5da17a..83342f762f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,14 +8,27 @@ AC_CONFIG_SRCDIR([./xen/common/kernel.c])
AC_CONFIG_FILES([./config/Toplevel.mk])
AC_PREFIX_DEFAULT([/usr])
+AC_CANONICAL_HOST
+
m4_include([m4/features.m4])
m4_include([m4/subsystem.m4])
+dnl mini-os is only ported to certain platforms
+case "$host_cpu" in
+ i[[3456]]86|x86_64)
+ arch_enable_stubdom=y
+ ;;
+ *)
+ arch_enable_stubdom=n
+ ;;
+esac
+
AX_SUBSYSTEM_DEFAULT_ENABLE([xen])
AX_SUBSYSTEM_DEFAULT_ENABLE([kernels])
AX_SUBSYSTEM_DEFAULT_ENABLE([tools])
-AX_SUBSYSTEM_DEFAULT_ENABLE([stubdom])
+AX_SUBSYSTEM_CONDITIONAL([stubdom], $arch_enable_stubdom)
AX_SUBSYSTEM_DEFAULT_ENABLE([docs])
+
AX_SUBSYSTEM_FINISH
AC_OUTPUT()