aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 968d9de..efbeda7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,6 +8,9 @@
# $Id$
#
# $Log$
+# Revision 1.9 2008/02/13 16:57:29 james
+# *** empty log message ***
+#
# Revision 1.8 2008/02/13 09:12:20 james
# *** empty log message ***
#
@@ -38,11 +41,12 @@
INCLUDES=
-HDRS=ansi.h context.h crt.h history.h keys.h project.h prototypes.h \
- ring.h sympathy.h tty.h vt102.h
+PROJECTHDRS= crt.h tty.h ansi.h vt102.h keys.h history.h ring.h slide.h log.h ipc.h context.h prototypes.h
+
+HDRS=project.h
SRCS=ansi.c crt.c html.c libsympathy.c render.c version.c vt102.c tty.c \
- history.c ring.c ptty.c terminal.c util.c
+ history.c ring.c ptty.c terminal.c util.c log.c ipc.c slide.c
CPROTO=cproto
@@ -56,7 +60,7 @@ libsympathy_la_SOURCES = ${SYMPATHYSRCS}
libsympathy_a_CFLAGS = ${AM_CFLAGS}
-BUILT_SOURCES = version.h
+BUILT_SOURCES = version.h sympathy.h
lib_LIBRARIES=libsympathy.a
lib_LTLIBRARIES=libsympathy.la
@@ -85,6 +89,9 @@ protos:
tidy: ${SRCS} ${HDRS}
indent -i2 -ts0 ${SRCS} ${HDRS}
+sympathy.h: ${PROJECTHDRS} sympathy.h.head sympathy.h.tail
+ cat sympathy.h.head ${PROJECTHDRS} sympathy.h.tail > $@ || /bin/rm -f $@
+
version.h: $(VFD)/version-files $(VFD)/version-major \
$(VFD)/version-minor $(VFD)/version-micro \
$(VFD)/version-md5sums ${VFS} Makefile