aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3afac2b..94f0f7b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,6 +8,9 @@
# $Id$
#
# $Log$
+# Revision 1.7 2008/02/12 22:36:46 james
+# *** empty log message ***
+#
# Revision 1.6 2008/02/09 15:47:28 james
# *** empty log message ***
#
@@ -30,15 +33,19 @@
#
#
-INCLUDES =
+INCLUDES=
+
+HDRS=ansi.h context.h crt.h history.h keys.h project.h prototypes.h \
+ ring.h sympathy.h tty.h vt102.h
+
+SRCS=ansi.c crt.c html.c libsympathy.c render.c version.c vt102.c tty.c \
+ history.c ring.c ptty.c
-SRCS= ansi.c crt.c html.c libsympathy.c render.c version.c vt102.c tty.c \
- history.c buf.c ptty.c
CPROTO=cproto
SYMPATHYSRCS=${SRCS}
-noinst_HEADERS= project.h prototypes.h
+noinst_HEADERS= prototypes.h ${HDRS}
libsympathy_a_SOURCES = ${SYMPATHYSRCS}
@@ -72,6 +79,9 @@ protos:
${CPROTO} -v ${INCLUDES} ${SRCS} > prototypes.tmp
mv -f prototypes.tmp prototypes.h
+tidy: ${SRCS} ${HDRS}
+ indent -i2 -ts0 ${SRCS} ${HDRS}
+
version.h: $(VFD)/version-files $(VFD)/version-major \
$(VFD)/version-minor $(VFD)/version-micro \
$(VFD)/version-md5sums ${VFS} Makefile