aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ad86f29..f38380b 100644
--- a/configure.in
+++ b/configure.in
@@ -89,7 +89,7 @@ dnl AC_DEFINE_UNQUOTED(LIBSYMPATHY_MICRO_VERSION, $LIBSYMPATHY_MICRO_VERSION)
AC_CHECK_HEADERS(fcntl.h malloc.h sys/ioctl.h unistd.h)
AC_CHECK_HEADERS(sys/scsi/impl/uscsi.h scsi/sg.h stdint.h)
AC_CHECK_HEADERS(sys/int_types.h string.h strings.h)
-AC_CHECK_HEADERS(dirent.h sys/stat.h)
+AC_CHECK_HEADERS(dirent.h sys/stat.h temrio.h)
AC_C_INLINE
AC_C_CONST
@@ -119,8 +119,12 @@ G2_HAVE_STDINT_H=0
if test "$ac_cv_header_stdint_h" = "yes"; then
G2_HAVE_STDINT_H=1
fi
+G2_HAVE_TERMIO_H=0
+if test "$ac_cv_header_termio_h" = "yes"; then
+ G2_HAVE_TERMIO_H=1
+fi
G2_TIME_WITH_SYS_TIME=0
-if test "$ac_cv_header_time_h" = "yes"; then
+if test "$ac_cv_header_sys_time_h" = "yes"; then
G2_TIME_WITH_SYS_TIME=1
fi
G2_TM_IN_SYS_TIME=0
@@ -137,6 +141,7 @@ AC_SUBST(G2_HAVE_SYS_INT_TYPES_H)
AC_SUBST(G2_HAVE_UNISTD_H)
AC_SUBST(G2_HAVE_MALLOC_H)
AC_SUBST(G2_HAVE_STDINT_H)
+AC_SUBST(G2_HAVE_TERMIO_H)
AC_SUBST(G2_TIME_WITH_SYS_TIME)
AC_SUBST(G2_TM_IN_SYS_TIME)