aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 25 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 91c7516..1db47fe 100644
--- a/configure.in
+++ b/configure.in
@@ -8,6 +8,9 @@ dnl
dnl $Id$
dnl
dnl $Log$
+dnl Revision 1.2 2008/02/13 18:05:06 james
+dnl *** empty log message ***
+dnl
dnl Revision 1.1 2008/02/03 16:20:23 james
dnl *** empty log message ***
dnl
@@ -96,17 +99,36 @@ G2_HAVE_UNISTD_H=0
if test "$ac_cv_header_unistd_h" = "yes"; then
G2_HAVE_UNISTD_H=1
fi
+G2_HAVE_MALLOC_H=0
+if test "$ac_cv_header_malloc_h" = "yes"; then
+ G2_HAVE_MALLOC_H=1
+fi
+G2_HAVE_STDINT_H=0
+if test "$ac_cv_header_stdint_h" = "yes"; then
+ G2_HAVE_STDINT_H=1
+fi
+G2_TIME_WITH_SYS_TIME=0
+if test "$ac_cv_header_time_h" = "yes"; then
+ G2_TIME_WITH_SYS_TIME=1
+fi
+G2_TM_IN_SYS_TIME=0
+if test "$ac_cv_struct_tm" = "sys/time.h"; then
+ G2_TM_IN_SYS_TIME=1
+fi
+
AC_SUBST(G2_TM_H)
AC_SUBST(G2_HAVE_STDINT_H)
AC_SUBST(G2_HAVE_SYS_INT_TYPES_H)
AC_SUBST(G2_HAVE_UNISTD_H)
-
-
+AC_SUBST(G2_HAVE_MALLOC_H)
+AC_SUBST(G2_HAVE_STDINT_H)
+AC_SUBST(G2_TIME_WITH_SYS_TIME)
+AC_SUBST(G2_TM_IN_SYS_TIME)
AC_OUTPUT([Makefile
src/Makefile
- src/sympathy.h
+ src/sympathy.h.head
test/Makefile
apps/Makefile
libsympathy-config.src],[chmod +x libsympathy-config.src])