aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorjames <>2008-02-27 15:18:08 +0000
committerjames <>2008-02-27 15:18:08 +0000
commit978f6e037320899ba9366005f50fa8cda84d3a58 (patch)
tree393a97d7703ac839c7c3e5586b66783de111bced /Makefile.am
parent74c2e130e079c977c3d2b431b49362d3b8fb250e (diff)
downloadsympathy-978f6e037320899ba9366005f50fa8cda84d3a58.tar.gz
sympathy-978f6e037320899ba9366005f50fa8cda84d3a58.tar.bz2
sympathy-978f6e037320899ba9366005f50fa8cda84d3a58.zip
*** empty log message ***
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3022ef0..e341690 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,9 @@
# $Id$
#
# $Log$
+# Revision 1.5 2008/02/27 15:17:55 james
+# *** empty log message ***
+#
# Revision 1.4 2008/02/27 15:04:32 james
# *** empty log message ***
#
@@ -30,7 +33,11 @@ man1_MANS=sympathy.man
bin_SCRIPTS = libsympathy-config
clean-local:
- -rm -f libsympathy-config version.sed
+ -rm -f libsympathy-config version.sed sympathy.man
+
+sympathy.man: sympathy.man.src version.sed
+ @SED@ -f version.sed < sympathy.man.src > sympathy.man || rm -f sympathy.man
+
libsympathy-config.src:libsympathy-config.src.in
libsympathy-config:libsympathy-config.src version.sed
@@ -43,17 +50,20 @@ VF=${shell cat ${VFD}/version-files}
VFS=${VF:%=${VFD}/%}
VCHK=${shell cat ${VFS} | @MD5SUM@ | @AWK@ '{print $$1 }' }
VNUM=${shell @GREP@ ${VCHK} ${VFD}/version-md5sums | @AWK@ '{ print $$2 }' }
+VSTP=${shell @GREP@ ${VCHK} ${VFD}/version-stamps | @AWK@ '{ print $$2 }' }
VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${VFD}/version-micro` }
-EXTRA_DIST=version-files version-major version-minor version-micro version-md5sums
+EXTRA_DIST=version-files version-major version-minor version-micro version-md5sums version-stamps
version.sed: $(VFD)/version-files $(VFD)/version-major \
$(VFD)/version-minor $(VFD)/version-micro \
- $(VFD)/version-md5sums ${VFS} Makefile
+ $(VFD)/version-md5sums $(VFD)/version-stamps ${VFS} Makefile
if [ .${VNUM} = . ]; then \
echo "s/%VERSION%/${VDEF}-E/g" > version.sed; \
+ echo "s/%VERSION%/After ${VSTP}/g" > version.sed; \
else \
echo "s/%VERSION%/${VNUM}/g" > version.sed; \
+ echo "s/%VERSIONSTAMP%/${VSTP}/g" > version.sed; \
fi
protos: