aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorjames <>2008-02-03 16:20:24 +0000
committerjames <>2008-02-03 16:20:24 +0000
commit4163308ecae26c76d22e4cc80d8bae729b06b94f (patch)
tree5d72762d62aaf3e8843123a967280623e3bd0f64 /Makefile.am
downloadsympathy-4163308ecae26c76d22e4cc80d8bae729b06b94f.tar.gz
sympathy-4163308ecae26c76d22e4cc80d8bae729b06b94f.tar.bz2
sympathy-4163308ecae26c76d22e4cc80d8bae729b06b94f.zip
*** empty log message ***
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..778ebd9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,42 @@
+#
+#
+# Makefile.am:
+#
+# Copyright (c) 2008 James McKenzie <james@fishsoup.dhs.org>,
+# All rights reserved.
+#
+# $Id$
+#
+# $Log$
+# Revision 1.1 2008/02/03 16:20:23 james
+# *** empty log message ***
+#
+#
+#
+#
+SUBDIRS=src apps test
+
+bin_SCRIPTS = libsympathy-config
+
+libsympathy-config.src:libsympathy-config.src.in
+libsympathy-config:libsympathy-config.src version.sed
+ @SED@ -f version.sed < libsympathy-config.src > libsympathy-config || rm -f libsympathy-config
+ chmod +x $@
+
+
+VFD=${srcdir}
+VF=${shell cat ${VFD}/version-files}
+VFS=${VF:%=${VFD}/%}
+VCHK=${shell cat ${VFS} | @MD5SUM@ | @AWK@ '{print $$1 }' }
+VNUM=${shell @GREP@ ${VCHK} ${VFD}/version-md5sums | @AWK@ '{ print $$2 }' }
+VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${VFD}/version-micro` }
+
+version.sed: $(VFD)/version-files $(VFD)/version-major \
+ $(VFD)/version-minor $(VFD)/version-micro \
+ $(VFD)/version-md5sums ${VFS} Makefile
+ if [ .${VNUM} = . ]; then \
+ echo "s/%VERSION%/${VDEF}-E/g" > version.sed; \
+ else \
+ echo "s/%VERSION%/${VNUM}/g" > version.sed; \
+ fi
+