aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorjames <>2008-02-27 18:29:49 +0000
committerjames <>2008-02-27 18:29:49 +0000
commit25a66d32e7f2978d36021fee8cf71800d2d6572d (patch)
tree31e2bcf9f3cd59d530d3c7fbeaf6ad59cb58acf5 /Makefile.am
parente14a8c751549c224b157f9689177b1a2f127ce20 (diff)
downloadsympathy-25a66d32e7f2978d36021fee8cf71800d2d6572d.tar.gz
sympathy-25a66d32e7f2978d36021fee8cf71800d2d6572d.tar.bz2
sympathy-25a66d32e7f2978d36021fee8cf71800d2d6572d.zip
*** empty log message ***
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index b82e068..a6250cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,6 +8,9 @@
# $Id$
#
# $Log$
+# Revision 1.7 2008/02/27 18:29:49 james
+# *** empty log message ***
+#
# Revision 1.6 2008/02/27 16:01:24 james
# *** empty log message ***
#
@@ -55,20 +58,21 @@ VCHK=${shell cat ${VFS} | @MD5SUM@ | @AWK@ '{print $$1 }' }
VNUM=${shell @GREP@ ${VCHK} ${VFD}/version-md5sums | @AWK@ '{ print $$2 }' }
VSTP=${shell @GREP@ ${VCHK} ${VFD}/version-stamps | @AWK@ 'BEGIN { FS="\t" }; { print $$2 }' }
VDEF=${shell echo `cat ${VFD}/version-major`.`cat ${VFD}/version-minor`.`cat ${VFD}/version-micro` }
+VSDF=${shell tail -1 ${VFD}/version-stamps | @AWK@ 'BEGIN { FS="\t" }; { print $$2 }' }
-EXTRA_DIST=version-files version-major version-minor version-micro version-md5sums version-stamps
+EXTRA_DIST=version-files version-major version-minor version-micro version-md5sums version-stamps sympathy.1
version.sed: $(VFD)/version-files $(VFD)/version-major \
$(VFD)/version-minor $(VFD)/version-micro \
$(VFD)/version-md5sums $(VFD)/version-stamps ${VFS} Makefile
if [ .${VNUM} = . ]; then \
echo "s/%VERSION%/${VDEF}-E/g" > version.sed; \
- echo "s/%VERSIONSTAMP%/After ${VSTP}/g" >> version.sed; \
- echo "s/%LONGVERSION%/libsympathy version ${VNUM} + Edits/g" >> version.sed; \
+ echo "s/%VERSIONSTAMP%/After ${VSDF}/g" >> version.sed; \
+ echo "s/%LONGVERSION%/Version ${VDEF} + Edits/g" >> version.sed; \
else \
echo "s/%VERSION%/${VNUM}/g" > version.sed; \
echo "s/%VERSIONSTAMP%/${VSTP}/g" >> version.sed; \
- echo "s/%LONGVERSION%/libsympathy version ${VNUM}/g" >> version.sed; \
+ echo "s/%LONGVERSION%/Version ${VNUM}/g" >> version.sed; \
fi
protos: