aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 21 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da2463f..dafcc87 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ HSRCS=project.h prototypes.h
noinst_HEADERS=${HSRCS}
bin_PROGRAMS = ext_clone
-CSRCS= clone_data.c clone_ea.c clone_extents.c clone_inode.c ea_map.c ext_clone.c stats.c clone_fs.c zap_fs.c zap_inode.c
+CSRCS= clone_data.c clone_ea.c clone_extents.c clone_inode.c ea_map.c ext_clone.c stats.c clone_fs.c zap_fs.c zap_inode.c clone_blocks.c
ext_clone_SOURCES = ${CSRCS}
ext_clone_LDADD = ${LIBE2P_LIB} ${LIBEXT2FS_LIB} ${LIBCOM_ERR_LIB} ${LIBDB_LIB} -lm
@@ -23,12 +23,26 @@ src.img:
mkdir -p src
rm -f src.img
truncate -s 128M src.img
- mkfs.ext4 -b 4096 -O 64bit -E stride=16,stripe-width=112 src.img
+ mkfs.ext3 -b 4096 -E stride=16,stripe-width=112 src.img
+ mount src.img src
+ mkdir src/ext3
+ (cd src/ext3 && git clone git://git.panaceas.org/tools/sympathy )
+ (cd src/ext3 && truncate -s 256m holey && dd if=/dev/urandom of=holey conv=notrunc,nocreat bs=1024k seek=37 count=1 )
+ (cd src/ext3 && ln holey linky)
+ (cd src/ext3 && touch empty)
+ (cd src/ext3 && ln -s holey slinky)
+ umount src
+ tune2fs -O extents,uninit_bg,dir_index,has_journal src.img
+ mount src.img src
+ mkdir src/ext4
+ (cd src/ext4 && git clone git://git.panaceas.org/tools/sympathy )
+ (cd src/ext4 && truncate -s 256m holey && dd if=/dev/urandom of=holey conv=notrunc,nocreat bs=1024k seek=37 count=1 )
+ (cd src/ext4 && ln holey linky)
+ (cd src/ext4 && touch empty)
+ (cd src/ext4 && ln -s holey slinky)
+ umount src
+ e2fsck -f -y src.img
mount src.img src
- (cd src && git clone git://git.panaceas.org/tools/sympathy )
- (cd src && truncate -s 8g holey && dd if=/dev/zero of=holey conv=notrunc,nocreat bs=1024k seek=4000 count=1 )
- (cd src && ln holey linky)
- (cd src && touch empty)
ls -lZR src
ls -lR src
umount src
@@ -56,7 +70,7 @@ test: ext_clone src.img
mkdir -p dst
mount -o ro src.img src
mount -o ro dst.img dst
- rsync -varX -n src/ dst/
+ rsync -vScarX -n src/ dst/
umount dst
umount src
rmdir src