aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar7240_buffalo_whr-g301n.dts
Commit message (Collapse)AuthorAgeFilesLines
* ath79: convert mtd-mac-address to nvmem implementationAnsuel Smith2021-07-191-3/+16
| | | | | | | Define nvmem-cells and convert mtd-mac-address to nvmem implementation. The conversion is done with an automated script. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
* treewide: convert mtd-mac-address-increment* to generic implementationAnsuel Smith2021-07-191-1/+1
| | | | | | | | | | | | | Rework patch 681-NET-add-mtd-mac-address-support to implement only the function to read the mac-address from mtd. Generalize mtd-mac-address-increment function so it can be applied to any source of of_get_mac_address. Rename any mtd-mac-address-increment to mac-address-increment. Rename any mtd-mac-address-increment-byte to mac-address-increment-byte. This should make simplify the conversion of target to nvmem implementation. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
* ath79: enable UART in SoC DTSI filesAdrian Schmutzler2021-02-241-4/+0
| | | | | | | | | | | | | | | The uart node is enabled on all devices except one (GL-USB150 *). Thus, let's not have a few hundred nodes to enable it, but do not disable it in the first place. Where the majority of devices is using it, also move the serial0 alias to the DTSI. *) Since GL-USB150 even defines serial0 alias, the missing uart is probably just a mistake. Anyway, disable it for now so this patch stays cosmetic. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* ath79: drop num-cs for SPI controllerAdrian Schmutzler2020-12-041-2/+0
| | | | | | | | None of the spi drivers on ath79 uses the num-cs property. Cc: Chuanhong Guo <gch981213@gmail.com> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Chuanhong Guo <gch981213@gmail.com>
* ath79: remove model name from LED labelsAdrian Schmutzler2020-10-021-9/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, we request LED labels in OpenWrt to follow the scheme modelname:color:function However, specifying the modelname at the beginning is actually entirely useless for the devices we support in OpenWrt. On the contrary, having this part actually introduces inconvenience in several aspects: - We need to ensure/check consistency with the DTS compatible - We have various exceptions where not the model name is used, but the vendor name (like tp-link), which is hard to track and justify even for core-developers - Having model-based components will not allow to share identical LED definitions in DTSI files - The inconsistency in what's used for the model part complicates several scripts, e.g. board.d/01_leds or LED migrations from ar71xx where this was even more messy Apart from our needs, upstream has deprecated the label property entirely and introduced new properties to specify color and function properties separately. However, the implementation does not appear to be ready and probably won't become ready and/or match our requirements in the foreseeable future. However, the limitation of generic LEDs to color and function properties follows the same idea pointed out above. Generic LEDs will get names like "green:status" or "red:indicator" then, and if a "devicename" is prepended, it will be the one of an internal device, like "phy1:amber:status". With this patch, we move into the same direction, and just drop the boardname from the LED labels. This allows to consolidate a few definitions in DTSI files (will be much more on ramips), and to drop a few migrations compared to ar71xx that just changed the boardname. But mainly, it will liberate us from a completely useless subject to take care of for device support review and maintenance. To also drop the boardname from existing configurations, a simple migration routine is added unconditionally. Although this seems unfamiliar at first look, a quick check in kernel for the arm/arm64 dts files revealed that while 1033 lines have labels with three parts *:*:*, still 284 actually use a two-part labelling *:*, and thus is also acceptable and not even rare there. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* ath79: move dts-v1 statement to ath79.dtsiAdrian Schmutzler2020-09-251-3/+2
| | | | | | | | | | | | | | | | | | | The "/dts-v1/;" identifier is supposed to be present once at the top of a device tree file after the includes have been processed. In ath79, we therefore requested to have in the DTS files so far, and omit it in the DTSI files. However, essentially the syntax of the parent ath79.dtsi file already determines the DTS version, so putting it into the DTS files is just a useless repetition. Consequently, this patch puts the dts-v1 statement into the parent ath79.dtsi, which is (indirectly) included by all DTS files. All other occurences are removed. Since the dts-v1 statement needs to be before any other definitions, this also moves the includes to make sure the ath79.dtsi or its descendants are always included first. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* ath79: ar724x: make sure builtin-switch is enabled in DTAdrian Schmutzler2020-08-171-2/+0
| | | | | | | | | | | | | | | | | | | On ar7240/ar7241 the mdioX node with the builtin-switch is enabled in the DTSI files, but the parent ethX node is left disabled. It only gets enabled per device or device family, and has not been enabled at all yet for the TP-Link WA devices with ar7240, making the switch unavailable there. This patch makes sure &eth0/&eth1 nodes are enabled together with the &mdio0/&mdio1 nodes containing the builtin-switch. For ar7240_tplink_tl-wa.dtsi, &eth0 is properly hidden again via compatible = "syscon", "simple-mfd"; This partially fixes FS#2887, however it seems dmesg still does not show cable (dis)connect in dmesg for ar7240 TP-Link WA devices. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* ath79: DTS file style update and harmonizationAdrian Schmutzler2019-11-061-5/+6
| | | | | | | | | | | | | | | | | | This applies several style adjustments that have been requested in recent reviews to older DTS files. Despite making the code base more consistent, this will also help to reduce review time when DTSes are copy/pasted. Applied changes: - Rename gpio-keys/gpio-leds to keys/leds - Remove node labels that are not used - Use label property for partitions - Prefix led node labels with "led_" - Remove redundant includes - Harmonize new lines after status property - Several smaller style fixes Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
* ath79: convert devices to interrupt-driven gpio-keysAdrian Schmutzler2019-09-221-2/+1
| | | | | | | | | | | | | This converts all remaining devices to use interrupt-driven gpio-keys compatible instead of gpio-keys-polled. The poll-interval is removed. Only ar7240_netgear_wnr612-v2 is kept at gpio-keys-polled, as this one is using ath9k keys. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Karl Palsson <karlp@etactica.com> Tested-by: Dmitry Tunin <hanipouspilot@gmail.com>
* ath79: dts: Unify naming of gpio-keys nodesPetr Štetiar2019-01-261-1/+1
| | | | | | | | | | | | | | In DTS Checklist[1] we're now demanding proper generic node names, as the name of a node should reflect the function of the device and use generic name for that[2]. Everybody seems to be copy&pasting from DTS files available in the repository today, so let's unify that naming there as well and provide proper examples. 1. https://openwrt.org/submitting-patches#dts_checklist 2. https://github.com/devicetree-org/devicetree-specification/blob/master/source/devicetree-basics.rst#generic-names-recommendation Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [split up]
* treewide: dts: Remove default-state=off property from all gpio LED nodesPetr Štetiar2018-12-171-1/+0
| | | | | | | | | | | | | | | | | | >From the Documentation/devicetree/bindings/leds/common.txt: - default-state : The initial state of the LED. Valid values are "on", "off", and "keep". If the LED is already on or off and the default-state property is set the to same value, then no glitch should be produced where the LED momentarily turns off (or on). The "keep" setting will keep the LED at whatever its current state is, without producing a glitch. The default is off if this property is not present. So setting the default-state of the LEDs to `off` is redundant as `off` is default LED state anyway. We should remove it as almost every new PR/patch submission contains this property by default which seems to be just copy&paste from some DTS file already present in the tree. Signed-off-by: Petr Štetiar <ynezz@true.cz>
* ath79: specify "firmware" partition format for Buffalo devicesINAGAKI Hiroshi2018-11-261-0/+1
| | | | | | | | | | | | | | Specify firmware partition format (denx,uimage) by compatible string for Buffalo devices. affected devices (&run tested): - BHR-4GRV - WHR-G301N - WZR-HP-AG300H - WZR-HP-G302H A1A0 - WZR-HP-G450H (WZR-450HP) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
* ath79: add support for Buffalo WHR-G301NINAGAKI Hiroshi2018-08-161-0/+192
Buffalo WHR-G301N is a 2.4 GHz 11n router, based on Atheros AR7240. Ported from ar71xx target. Specification: - Atheros AR7240 - 32 MB of RAM - 4 MB of Flash - 2.4 GHz 2T2R wifi - 5x 10/100 Mbps Ethernet - 9x LEDs, 4x keys - LED: 8x gpio-leds, 1x ath9k-leds - key: 2x buttons, 1x slide switch - UART header on PCB - Vcc, GND, TX, RX from LEDs side - 115200n8 Flash instruction using factory image: 1. Connect the computer to the LAN port of WHR-G301N 2. Connect power cable to WHR-G301N and turn on it 3. Access to "http://192.168.11.1/" and open firmware update page ("ファーム更新") 4. Select the OpenWrt factory image and click execute ("実行") button 5. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [fix the SUPPORTED_DEVICES to be compatible with the ar71xx image] Signed-off-by: Mathias Kresin <dev@kresin.me>