aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/ccache/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index b4dc81aaaa..3db6cc0818 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -25,6 +25,9 @@ CMAKE_HOST_OPTIONS += \
-DCMAKE_SKIP_RPATH=FALSE \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
+CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
+endif
define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/