aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorDavid Adair <djabhead@aol.com>2021-05-14 16:04:27 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:11:38 +0200
commit2d1546832357a3a8bd18680bd31dd92050e739b2 (patch)
tree0b5cd5f8d8374a4cde549ee06a045c55502d2c8e /tools
parentb054009854d3aa5bdba24334673cd56a4a6f9a5a (diff)
downloadupstream-2d1546832357a3a8bd18680bd31dd92050e739b2.tar.gz
upstream-2d1546832357a3a8bd18680bd31dd92050e739b2.tar.bz2
upstream-2d1546832357a3a8bd18680bd31dd92050e739b2.zip
ccache: Build with ENABLE_DOCUMENTATION=OFF
This adjusts the Makefile to use the new option to turn off the doc builds. It will not cause any problems except a warning about unused options if combined with a ccache source missing the upstream patch. Since a config setting is required to re-enable the doc build this is equivalent to unconditionally disabling the docs if the config setting is not created. Signed-off-by: David Adair <djabhead@aol.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/ccache/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index b4dc81aaaa..3db6cc0818 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -25,6 +25,9 @@ CMAKE_HOST_OPTIONS += \
-DCMAKE_SKIP_RPATH=FALSE \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
+CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
+endif
define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/