aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/patches/210-link-libcrypto-static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkimage/patches/210-link-libcrypto-static.patch')
-rw-r--r--tools/mkimage/patches/210-link-libcrypto-static.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/mkimage/patches/210-link-libcrypto-static.patch b/tools/mkimage/patches/210-link-libcrypto-static.patch
new file mode 100644
index 0000000000..66412ce43b
--- /dev/null
+++ b/tools/mkimage/patches/210-link-libcrypto-static.patch
@@ -0,0 +1,14 @@
+OpenWrt links the libressl statically against mkimage, make sure all the
+needed dependencies are added too.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -145,7 +145,7 @@ endif
+ # MXSImage needs LibSSL
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
+ HOSTLOADLIBES_mkimage += \
+- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
++ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
+
+ # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
+ # warnings on those systems