aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index fbcf87cfc6..dc1aec18a0 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2018.03
+PKG_VERSION:=2019.07
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ftp.denx.de/pub/u-boot
-PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
+PKG_HASH:=bff4fa77e8da17521c030ca4c5b947a056c1b1be4d3e6ee8637020b8d50251d0
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -29,7 +29,9 @@ define Host/Compile
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
no-dot-config-targets=tools-only \
CONFIG_MKIMAGE_DTC_PATH=dtc \
+ CONFIG_FIT=y \
CONFIG_FIT_SIGNATURE=y \
+ CONFIG_FIT_SIGNATURE_MAX_SIZE=0x10000000 \
tools-only
endef