aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/100-disable_qt_tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cmake/patches/100-disable_qt_tests.patch')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index f8baafe333..6e8307dea4 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -246,15 +246,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,14 +18,17 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -403,10 +403,6 @@ if(BUILD_TESTING)
+@@ -407,13 +407,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
-- if(NOT QT4_FOUND)
+- if(NOT DEFINED CMake_TEST_Qt4)
+- set(CMake_TEST_Qt4 1)
+- endif()
+- if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
- find_package(Qt4 QUIET)
- endif()
-
- if(QT4_FOUND)
+ if(CMake_TEST_Qt4 AND QT4_FOUND)
# test whether the Qt4 which has been found works, on some machines
# which run nightly builds there were errors like "wrong file format"