aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison')
-rw-r--r--tools/bison/Makefile4
-rw-r--r--tools/bison/patches/100-fix-gets-removal.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index fde812f334..8f3043fcb8 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bison
-PKG_VERSION:=3.7.1
+PKG_VERSION:=3.7.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=55c215521a13982a9bee68cd42eed51a65713f96c530a739a57de4438ac1bb69
+PKG_HASH:=a3b5813f48a11e540ef26f46e4d288c0c25c7907d9879ae50e430ec49f63c010
HOST_BUILD_PARALLEL:=1
diff --git a/tools/bison/patches/100-fix-gets-removal.patch b/tools/bison/patches/100-fix-gets-removal.patch
index f97e8a3985..534713f180 100644
--- a/tools/bison/patches/100-fix-gets-removal.patch
+++ b/tools/bison/patches/100-fix-gets-removal.patch
@@ -1,6 +1,6 @@
--- a/lib/stdio.in.h
+++ b/lib/stdio.in.h
-@@ -816,14 +816,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+@@ -835,14 +835,6 @@ _GL_WARN_ON_USE (getline, "getline is un
# endif
#endif
@@ -12,6 +12,6 @@
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
-#endif
-
- #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
- struct obstack;
- /* Grow an obstack with formatted output. Return the number of
+ #if defined _WIN32 && !defined __CYGWIN__
+ # undef getw
+ # define getw _getw