aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/patches/120-more_standard_math.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/uClibc/patches/120-more_standard_math.patch')
-rw-r--r--toolchain/uClibc/patches/120-more_standard_math.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches/120-more_standard_math.patch b/toolchain/uClibc/patches/120-more_standard_math.patch
new file mode 100644
index 0000000000..f7d626ac03
--- /dev/null
+++ b/toolchain/uClibc/patches/120-more_standard_math.patch
@@ -0,0 +1,12 @@
+diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
+--- uClibc.old/libm/Makefile 2005-08-18 00:49:41.000000000 +0200
++++ uClibc.dev/libm/Makefile 2005-10-22 00:56:03.106683500 +0200
+@@ -81,6 +81,8 @@
+ w_cosh.c w_exp.c s_fabs.c s_floor.c w_fmod.c s_frexp.c \
+ s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
+ w_sinh.c w_sqrt.c s_tan.c s_tanh.c
++# extra stuff required for some apps
++CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
+ CSRC+= s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
+ k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
+ k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \