aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/libnotimpl
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/libnotimpl')
-rw-r--r--toolchain/libnotimpl/Makefile39
-rw-r--r--toolchain/libnotimpl/src/math.c68
2 files changed, 107 insertions, 0 deletions
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
new file mode 100644
index 0000000000..85156723be
--- /dev/null
+++ b/toolchain/libnotimpl/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnotimpl
+
+PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/libnotimpl
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define cc
+ $(TARGET_CC) $(TARGET_CFLAGS) -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
+endef
+
+define Build/Prepare
+ rm -rf $(PKG_BUILD_DIR)
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile
+ $(call cc,math)
+ $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
+endef
+
+define Build/Install
+ mkdir -p $(STAGING_DIR)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libnotimpl.a $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/usr/lib/libnotimpl.a
+endef
+
+$(eval $(call HostBuild))
+
diff --git a/toolchain/libnotimpl/src/math.c b/toolchain/libnotimpl/src/math.c
new file mode 100644
index 0000000000..5bfcb9532e
--- /dev/null
+++ b/toolchain/libnotimpl/src/math.c
@@ -0,0 +1,68 @@
+/* vi: set sw=4 ts=4: */
+
+#include "math.h"
+
+
+/* cosf for uClibc
+ *
+ * wrapper for cos(x)
+ */
+
+#ifdef __STDC__
+ float cosf(float x)
+#else
+ float cosf(x)
+ float x;
+#endif
+{
+ return (float) cos( (double)x );
+}
+
+
+/* sinf for uClibc
+ *
+ * wrapper for sin(x)
+ */
+
+#ifdef __STDC__
+ float sinf(float x)
+#else
+ float sinf(x)
+ float x;
+#endif
+{
+ return (float) sin( (double)x );
+}
+
+
+/* ceilf for uClibc
+ *
+ * wrapper for ceil(x)
+ */
+
+#ifdef __STDC__
+ float ceilf(float x)
+#else
+ float ceilf(x)
+ float x;
+#endif
+{
+ return (float) ceil( (double)x );
+}
+
+
+/* rintf for uClibc
+ *
+ * wrapper for rint(x)
+ */
+
+#ifdef __STDC__
+ float rintf(float x)
+#else
+ float rintf(x)
+ float x;
+#endif
+{
+ return (float) sin( (double)x );
+}
+