aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/jffs2
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/jffs2')
-rw-r--r--toolchain/jffs2/Makefile34
-rw-r--r--toolchain/jffs2/patches/100-gcc4_fix.patch24
2 files changed, 0 insertions, 58 deletions
diff --git a/toolchain/jffs2/Makefile b/toolchain/jffs2/Makefile
deleted file mode 100644
index a0a26776f7..0000000000
--- a/toolchain/jffs2/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mtd
-PKG_VERSION:=20050122
-
-PKG_SOURCE=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL=http://ftp.debian.org/debian/pool/main/m/mtd
-PKG_MD5SUM:=1f42c2cae08eb9e7b52d0c188f8d6338
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)/util LINUXDIR=$(LINUX_HEADERS_DIR)
-endef
-
-define Build/Install
- mkdir -p $(STAGING_DIR)/bin
- $(CP) $(PKG_BUILD_DIR)/util/mkfs.jffs2 $(STAGING_DIR)/bin/
-endef
-
-define Build/Clean
- rm -f $(STAGING_DIR)/bin/mkfs.jffs2
-endef
-
-$(eval $(call HostBuild))
diff --git a/toolchain/jffs2/patches/100-gcc4_fix.patch b/toolchain/jffs2/patches/100-gcc4_fix.patch
deleted file mode 100644
index 50c8edb47e..0000000000
--- a/toolchain/jffs2/patches/100-gcc4_fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN mtd-20050122.orig.old/include/mtd/jffs2-user.h mtd-20050122.orig.dev/include/mtd/jffs2-user.h
---- mtd-20050122.orig.old/include/mtd/jffs2-user.h 2004-05-05 13:57:54.000000000 +0200
-+++ mtd-20050122.orig.dev/include/mtd/jffs2-user.h 2005-07-02 10:03:09.000000000 +0200
-@@ -19,8 +19,6 @@
- #undef je32_to_cpu
- #undef jemode_to_cpu
-
--extern int target_endian;
--
- #define t16(x) ({ uint16_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_16(__b); })
- #define t32(x) ({ uint32_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_32(__b); })
-
-diff -urN mtd.old/util/jffs3.h mtd.dev/util/jffs3.h
---- mtd.old/util/jffs3.h 2005-01-22 00:00:13.000000000 +0100
-+++ mtd.dev/util/jffs3.h 2005-07-17 17:48:24.000000000 +0200
-@@ -177,8 +177,6 @@
- #undef je32_to_cpu
- #undef jemode_to_cpu
-
--extern int target_endian;
--
- #define t16(x) ({ uint16_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_16(__b); })
- #define t32(x) ({ uint32_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_32(__b); })
-