aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 090aa2447d..7fb30285aa 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -115,7 +115,8 @@ GCC_CONFIGURE:= \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--with-mpc=$(TOPDIR)/staging_dir/host \
--disable-decimal-float \
- --with-diagnostics-color=auto-if-env
+ --with-diagnostics-color=auto-if-env \
+ --enable-__cxa_atexit
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt
endif
@@ -150,14 +151,6 @@ ifdef CONFIG_sparc
--with-long-double-128
endif
-ifeq ($(LIBC),uClibc)
- GCC_CONFIGURE+= \
- --disable-__cxa_atexit
-else
- GCC_CONFIGURE+= \
- --enable-__cxa_atexit
-endif
-
ifneq ($(GCC_ARCH),)
GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
endif