aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-18 16:06:15 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-04-26 21:45:41 +0200
commitcf22c4435e3bcf33e407cab71f7ff48aa00b4ac8 (patch)
treef0c7adc4cf73939ce8a4d398a00c471735e96fd5 /toolchain/gcc
parent5d81b28a829ac20fb60991e71ee7a7c53d14fd58 (diff)
downloadupstream-cf22c4435e3bcf33e407cab71f7ff48aa00b4ac8.tar.gz
upstream-cf22c4435e3bcf33e407cab71f7ff48aa00b4ac8.tar.bz2
upstream-cf22c4435e3bcf33e407cab71f7ff48aa00b4ac8.zip
toolchain/gcc: eliminate uClibc atexit hack
This seems to be over 10 years old. It doesn't seem to be needed anymore. Tested on malta with uClibc (selected BROKEN). Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 090aa2447d..7fb30285aa 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -115,7 +115,8 @@ GCC_CONFIGURE:= \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--with-mpc=$(TOPDIR)/staging_dir/host \
--disable-decimal-float \
- --with-diagnostics-color=auto-if-env
+ --with-diagnostics-color=auto-if-env \
+ --enable-__cxa_atexit
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt
endif
@@ -150,14 +151,6 @@ ifdef CONFIG_sparc
--with-long-double-128
endif
-ifeq ($(LIBC),uClibc)
- GCC_CONFIGURE+= \
- --disable-__cxa_atexit
-else
- GCC_CONFIGURE+= \
- --enable-__cxa_atexit
-endif
-
ifneq ($(GCC_ARCH),)
GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
endif