aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 4bc8b20271..6e8767f707 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -161,9 +161,13 @@ ifneq ($(GCC_ARCH),)
GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
endif
-ifneq ($(CONFIG_SOFT_FLOAT),y)
- ifeq ($(CONFIG_arm),y)
+ifeq ($(CONFIG_arm),y)
+ GCC_CONFIGURE+= \
+ --with-cpu=$(word 1, $(subst +," ,$(CONFIG_CPU_TYPE)))
+
+ ifneq ($(CONFIG_SOFT_FLOAT),y)
GCC_CONFIGURE+= \
+ --with-fpu=$(word 2, $(subst +, ",$(CONFIG_CPU_TYPE))) \
--with-float=hard
endif
endif