aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Config.in8
-rw-r--r--toolchain/binutils/Config.version4
-rw-r--r--toolchain/binutils/Makefile6
3 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index 61529c2f1e..8fe33fb6b7 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -3,7 +3,7 @@
choice
prompt "Binutils Version" if TOOLCHAINOPTS
default BINUTILS_USE_VERSION_2_28 if !arc
- default BINUTILS_USE_VERSION_2_27_ARC if arc
+ default BINUTILS_USE_VERSION_2_28_ARC if arc
help
Select the version of binutils you wish to use.
@@ -17,10 +17,10 @@ choice
bool "Binutils 2.28"
select BINUTILS_VERSION_2_28
- config BINUTILS_USE_VERSION_2_27_ARC
+ config BINUTILS_USE_VERSION_2_28_ARC
depends on arc
- bool "ARC binutils 2.27"
- select BINUTILS_VERSION_2_27_ARC
+ bool "ARC binutils 2.28"
+ select BINUTILS_VERSION_2_28_ARC
endchoice
diff --git a/toolchain/binutils/Config.version b/toolchain/binutils/Config.version
index e85c6d7e11..1b223e4109 100644
--- a/toolchain/binutils/Config.version
+++ b/toolchain/binutils/Config.version
@@ -5,7 +5,7 @@ config BINUTILS_VERSION_2_28
default y if (!TOOLCHAINOPTS && !arc)
bool
-config BINUTILS_VERSION_2_27_ARC
+config BINUTILS_VERSION_2_28_ARC
default y if (!TOOLCHAINOPTS && arc)
bool
@@ -13,4 +13,4 @@ config BINUTILS_VERSION
string
default "2.27" if BINUTILS_VERSION_2_27
default "2.28" if BINUTILS_VERSION_2_28
- default "arc-2016.09" if BINUTILS_VERSION_2_27_ARC
+ default "arc-2017.03" if BINUTILS_VERSION_2_28_ARC
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 459f54587b..6df11fbd3c 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -21,11 +21,11 @@ ifeq ($(PKG_VERSION),2.28)
PKG_HASH:=6297433ee120b11b4b0a1c8f3512d7d73501753142ab9e2daa13c5a3edd32a72
endif
-ifneq ($(CONFIG_BINUTILS_VERSION_2_27_ARC),)
- PKG_REV:=arc-2016.09-release
+ifneq ($(CONFIG_BINUTILS_VERSION_2_28_ARC),)
+ PKG_REV:=arc-2017.03-release
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/$(PKG_REV)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_REV).tar.gz
- PKG_HASH:=c6de8aedb7568406d784295476de9139a5e351e970e18b602e0037439b3a7b4b
+ PKG_HASH:=f9c1e09ef10aaf9619181f49587f464ba0a70d29b7f6f879047140acac852409
BINUTILS_DIR:=$(PKG_NAME)-gdb-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
endif