aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
new file mode 100644
index 0000000000..e36758fe4c
--- /dev/null
+++ b/toolchain/binutils/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=binutils
+PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))#"))
+
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
+ ftp://gatekeeper.dec.com/pub/GNU/ \
+ ftp://ftp.uu.net/archive/systems/gnu/ \
+ ftp://ftp.eu.uu.net/pub/gnu/ \
+ ftp://ftp.funet.fi/pub/gnu/prep/ \
+ ftp://ftp.leo.org/pub/comp/os/unix/gnu/
+
+PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=unknown
+PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ if [ -d ./patches/$(PKG_VERSION) ]; then \
+ $(SCRIPT_DIR)/patch-kernel.sh $(PKG_BUILD_DIR) ./patches/$(PKG_VERSION); \
+ fi
+endef
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); \
+ ./configure \
+ --prefix=$(STAGING_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --disable-werror \
+ --disable-nls \
+ );
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) -j $(CONFIG_JLEVEL) all
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) -j $(CONFIG_JLEVEL) install
+endef
+
+$(eval $(call HostBuild))