aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 34abda2376..7a9730fd68 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -70,15 +70,15 @@ endif
endif
ifdef CONFIG_BUILDBOT
- $(STAGING_DIR)/.toolchain_ver_check: $(TMP_DIR)/.build
- cd "$(TOPDIR)"; git log --format=%h -1 > $(TMP_DIR)/.toolchain_ver_check
- cmp -s $(TMP_DIR)/.toolchain_ver_check $@ || \
- rm -rf $(BUILD_DIR) $(STAGING_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR_TOOLCHAIN)
- mkdir -p $(STAGING_DIR)
- mv $(TMP_DIR)/.toolchain_ver_check $@
+ $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
+ cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
+ cmp -s $(TMP_DIR)/.ver_check $@ || { \
+ rm -rf $(BUILD_DIR) $(STAGING_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR_TOOLCHAIN); \
+ mkdir -p $(TOOLCHAIN_DIR)/stamp; \
+ mv $(TMP_DIR)/.ver_check $@; \
+ }
-$(STAGING_DIR)/.prepared: $(STAGING_DIR)/.toolchain_ver_check
-$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed: $(STAGING_DIR)/.prepared
+$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
endif
# prerequisites for the individual targets