aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/modules.mk3
-rw-r--r--target/linux/ramips/modules.mk2
2 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index 0788a6eda3..9696fe3b4c 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -93,7 +93,8 @@ define KernelPackage/sound-soc-3dlab-nano-player
AUTOLOAD:=$(call AutoLoad,68,snd-soc-3dlab-nano-player)
DEPENDS:= \
@LINUX_4_14 \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
endef
define KernelPackage/sound-soc-3dlab-nano-player/description
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 36f46e2b35..b604110b1e 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -116,7 +116,7 @@ $(eval $(call KernelPackage,hsdma-mtk))
define KernelPackage/sound-mt7620
TITLE:=MT7620 PCM/I2S Alsa Driver
- DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap-mmio +kmod-dma-ralink @!TARGET_ramips_rt288x
+ DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap-i2c +kmod-dma-ralink @!TARGET_ramips_rt288x
KCONFIG:= \
CONFIG_SND_RALINK_SOC_I2S \
CONFIG_SND_SIMPLE_CARD \