aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/DIR-810L.dts8
-rw-r--r--target/linux/ramips/image/mt7620.mk3
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/DIR-810L.dts b/target/linux/ramips/dts/DIR-810L.dts
index b38290af53..c6d437820d 100644
--- a/target/linux/ramips/dts/DIR-810L.dts
+++ b/target/linux/ramips/dts/DIR-810L.dts
@@ -143,3 +143,11 @@
&wmac {
ralink,mtd-eeprom = <&factory 0>;
};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index bf04a75ea1..a7aeaf130c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -154,8 +154,9 @@ TARGET_DEVICES += dch-m225
define Device/dir-810l
DTS := DIR-810L
- IMAGE_SIZE := 6720k
+ DEVICE_PACKAGES := kmod-mt76x0e
DEVICE_TITLE := D-Link DIR-810L
+ IMAGE_SIZE := 6720k
endef
TARGET_DEVICES += dir-810l