aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts (renamed from target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts)4
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds2
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
5 files changed, 10 insertions, 9 deletions
diff --git a/target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts b/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
index a43ed2afdc..0e2183c27d 100644
--- a/target/linux/ath79/dts/ar7241_ubnt_bullet-m.dts
+++ b/target/linux/ath79/dts/ar7241_ubnt_bullet-m-ar7241.dts
@@ -6,8 +6,8 @@
#include "ar724x_ubnt_xm_outdoor.dtsi"
/ {
- compatible = "ubnt,bullet-m", "ubnt,xm", "qca,ar7241";
- model = "Ubiquiti Bullet M";
+ compatible = "ubnt,bullet-m-ar7241", "ubnt,xm", "qca,ar7241";
+ model = "Ubiquiti Bullet M XM (AR7241)";
};
&eth1 {
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 390f5f3657..cf9dfd2b0d 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -245,7 +245,7 @@ tplink,tl-wr842n-v2)
trendnet,tew-823dru)
ucidef_set_led_netdev "wan" "WAN" "trendnet:green:planet" "eth0"
;;
-ubnt,bullet-m|\
+ubnt,bullet-m-ar7241|\
ubnt,bullet-m-xw|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-loco-m-xw|\
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 6f9aed8bf5..79313e9170 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -40,7 +40,7 @@ ath79_setup_interfaces()
tplink,re450-v1|\
tplink,re450-v2|\
tplink,tl-wr902ac-v1|\
- ubnt,bullet-m|\
+ ubnt,bullet-m-ar7241|\
ubnt,bullet-m-xw|\
ubnt,lap-120|\
ubnt,litebeam-ac-gen2|\
@@ -440,7 +440,7 @@ ath79_setup_macs()
label_mac=$wan_mac
;;
ubnt,airrouter|\
- ubnt,bullet-m|\
+ ubnt,bullet-m-ar7241|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-m|\
ubnt,picostation-m|\
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 52a1502af4..38f158896b 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -85,7 +85,7 @@ case "$FIRMWARE" in
tplink,tl-wr2543-v1|\
tplink,tl-wr842n-v1|\
ubnt,airrouter|\
- ubnt,bullet-m|\
+ ubnt,bullet-m-ar7241|\
ubnt,nanostation-loco-m|\
ubnt,nanostation-m|\
ubnt,picostation-m|\
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index aad177bf4a..4902023089 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -113,14 +113,15 @@ define Device/ubnt_airrouter
endef
TARGET_DEVICES += ubnt_airrouter
-define Device/ubnt_bullet-m
+define Device/ubnt_bullet-m-ar7241
$(Device/ubnt-xm)
SOC := ar7241
DEVICE_MODEL := Bullet-M
+ DEVICE_VARIANT := XM (AR7241)
DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += bullet-m
+ SUPPORTED_DEVICES += bullet-m ubnt,bullet-m
endef
-TARGET_DEVICES += ubnt_bullet-m
+TARGET_DEVICES += ubnt_bullet-m-ar7241
define Device/ubnt_bullet-m-xw
$(Device/ubnt-xw)