aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/layerscape/image/armv8_64b.mk9
-rw-r--r--target/linux/layerscape/modules.mk16
2 files changed, 24 insertions, 1 deletions
diff --git a/target/linux/layerscape/image/armv8_64b.mk b/target/linux/layerscape/image/armv8_64b.mk
index 5dd7ca955a..6ed3e7c155 100644
--- a/target/linux/layerscape/image/armv8_64b.mk
+++ b/target/linux/layerscape/image/armv8_64b.mk
@@ -103,6 +103,7 @@ define Device/fsl_ls1043a-rdb
layerscape-fman \
tfa-ls1043a-rdb \
fmc fmc-eth-config \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
@@ -126,6 +127,7 @@ define Device/fsl_ls1043a-rdb-sdboot
layerscape-fman \
tfa-ls1043a-rdb-sdboot \
fmc fmc-eth-config \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
@@ -157,6 +159,7 @@ define Device/fsl_ls1046a-rdb
layerscape-fman \
tfa-ls1046a-rdb \
fmc fmc-eth-config \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
@@ -180,6 +183,7 @@ define Device/fsl_ls1046a-rdb-sdboot
layerscape-fman \
tfa-ls1046a-rdb-sdboot \
fmc fmc-eth-config \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
@@ -212,6 +216,7 @@ define Device/fsl_ls1088a-rdb
layerscape-dpl \
tfa-ls1088a-rdb \
restool \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
IMAGE/firmware.bin := \
@@ -237,6 +242,7 @@ define Device/fsl_ls1088a-rdb-sdboot
layerscape-dpl \
tfa-ls1088a-rdb-sdboot \
restool \
+ kmod-ahci-qoriq \
kmod-hwmon-ina2xx \
kmod-hwmon-lm90
DEVICE_DTS := freescale/fsl-ls1088a-rdb
@@ -269,7 +275,8 @@ define Device/fsl_ls2088a-rdb
layerscape-mc \
layerscape-dpl \
tfa-ls2088a-rdb \
- restool
+ restool \
+ kmod-ahci-qoriq
IMAGE/firmware.bin := \
ls-clean | \
ls-append $(1)-bl2.pbl | pad-to 1M | \
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
index 5f2d472c95..4d713b597e 100644
--- a/target/linux/layerscape/modules.mk
+++ b/target/linux/layerscape/modules.mk
@@ -5,6 +5,22 @@
# See /LICENSE for more information.
#
+define KernelPackage/ahci-qoriq
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=Freescale QorIQ AHCI SATA support
+ KCONFIG:=CONFIG_AHCI_QORIQ
+ FILES:=$(LINUX_DIR)/drivers/ata/ahci_qoriq.ko
+ AUTOLOAD:=$(call AutoLoad,40,ahci-qoriq,1)
+ $(call AddDepends/ata,+kmod-ata-ahci-platform @TARGET_layerscape)
+endef
+
+define KernelPackage/ahci-qoriq/description
+ This option enables support for the Freescale QorIQ AHCI SoC's
+ onboard AHCI SATA.
+endef
+
+$(eval $(call KernelPackage,ahci-qoriq))
+
define KernelPackage/ppfe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Freescale PPFE Driver support