aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-2533ghbk2-t.dts40
-rw-r--r--target/linux/ramips/image/mt7621.mk14
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network1
3 files changed, 55 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-2533ghbk2-t.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-2533ghbk2-t.dts
new file mode 100644
index 0000000000..f17c2c7112
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-2533ghbk2-t.dts
@@ -0,0 +1,40 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_elecom_wrc-2533ghbk.dtsi"
+
+/ {
+ compatible = "elecom,wrc-2533ghbk2-t", "mediatek,mt7621-soc";
+ model = "ELECOM WRC-2533GHBK2-T";
+};
+
+&partitions {
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7a0000>;
+ };
+
+ partition@7f0000 {
+ label = "TM_1";
+ reg = <0x7f0000 0x200000>;
+ read-only;
+ };
+
+ partition@9f0000 {
+ label = "TM_2";
+ reg = <0x9f0000 0x400000>;
+ read-only;
+ };
+
+ partition@df0000 {
+ label = "manufacture";
+ reg = <0xdf0000 0x190000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "storage";
+ reg = <0xf80000 0x80000>;
+ read-only;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2269833e48..f2ca2a971d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -789,6 +789,20 @@ define Device/elecom_wrc-1900gst
endef
TARGET_DEVICES += elecom_wrc-1900gst
+define Device/elecom_wrc-2533ghbk2-t
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-2533GHBK2-T
+ IMAGE_SIZE := 7808k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elx-header 0107003b 8844A2D168B45A2D | \
+ elecom-product-header WRC-2533GHBK2-T
+ DEVICE_PACKAGES := kmod-mt7615-firmware
+endef
+TARGET_DEVICES += elecom_wrc-2533ghbk2-t
+
define Device/elecom_wrc-2533ghbk-i
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 9a8e385a31..027457d39c 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -174,6 +174,7 @@ ramips_setup_macs()
lan_mac=$(mtd_get_mac_ascii u-boot-env ethaddr)
wan_mac=$(mtd_get_mac_ascii u-boot-env wanaddr)
;;
+ elecom,wrc-2533ghbk2-t|\
elecom,wrc-2533ghbk-i)
lan_mac=$(mtd_get_mac_ascii u-boot-env ethaddr)
wan_mac=$(mtd_get_mac_ascii u-boot-env wanaddr)