aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/kirkwood/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/kirkwood/image/Makefile7
-rw-r--r--target/linux/kirkwood/patches-5.10/112-sheevaplug.patch47
-rw-r--r--target/linux/kirkwood/patches-5.4/112-sheevaplug.patch47
4 files changed, 102 insertions, 0 deletions
diff --git a/target/linux/kirkwood/base-files/etc/board.d/02_network b/target/linux/kirkwood/base-files/etc/board.d/02_network
index 0578691144..c379d13046 100644
--- a/target/linux/kirkwood/base-files/etc/board.d/02_network
+++ b/target/linux/kirkwood/base-files/etc/board.d/02_network
@@ -18,6 +18,7 @@ case "$board" in
;;
"cloudengines,pogoe02"|\
"cloudengines,pogoplugv4"|\
+"globalscale,sheevaplug"|\
"iom,iconnect-1.1"|\
"iom,ix2-200"|\
"raidsonic,ib-nas62x0"|\
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index e06eb050ef..c2c5bcab8f 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -67,6 +67,13 @@ define Device/cloudengines_pogoplugv4
endef
TARGET_DEVICES += cloudengines_pogoplugv4
+define Device/globalscale_sheevaplug
+ DEVICE_VENDOR := Globalscale
+ DEVICE_MODEL := Sheevaplug
+ DEVICE_PACKAGES := kmod-mvsdio
+endef
+TARGET_DEVICES += globalscale_sheevaplug
+
define Device/iom_iconnect-1.1
DEVICE_VENDOR := Iomega
DEVICE_MODEL := Iconnect
diff --git a/target/linux/kirkwood/patches-5.10/112-sheevaplug.patch b/target/linux/kirkwood/patches-5.10/112-sheevaplug.patch
new file mode 100644
index 0000000000..d1ff9884a0
--- /dev/null
+++ b/target/linux/kirkwood/patches-5.10/112-sheevaplug.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/boot/dts/kirkwood-sheevaplug-common.dtsi
++++ b/arch/arm/boot/dts/kirkwood-sheevaplug-common.dtsi
+@@ -78,13 +78,8 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
+- };
+-
+- partition@500000 {
+- label = "root";
+- reg = <0x0500000 0x1fb00000>;
++ label = "ubi";
++ reg = <0x0100000 0x1ff00000>;
+ };
+ };
+
+--- a/arch/arm/boot/dts/kirkwood-sheevaplug.dts
++++ b/arch/arm/boot/dts/kirkwood-sheevaplug.dts
+@@ -13,6 +13,13 @@
+ model = "Globalscale Technologies SheevaPlug";
+ compatible = "globalscale,sheevaplug", "marvell,kirkwood-88f6281", "marvell,kirkwood";
+
++ aliases {
++ led-boot = &led_health;
++ led-failsafe = &led_health;
++ led-running = &led_health;
++ led-upgrade = &led_health;
++ };
++
+ ocp@f1000000 {
+ mvsdio@90000 {
+ pinctrl-0 = <&pmx_sdio>;
+@@ -28,10 +35,10 @@
+ pinctrl-0 = <&pmx_led_blue &pmx_led_red>;
+ pinctrl-names = "default";
+
+- health {
++ led_health: health {
+ label = "sheevaplug:blue:health";
+ gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
+- default-state = "keep";
++ default-state = "on";
+ };
+
+ misc {
diff --git a/target/linux/kirkwood/patches-5.4/112-sheevaplug.patch b/target/linux/kirkwood/patches-5.4/112-sheevaplug.patch
new file mode 100644
index 0000000000..d1ff9884a0
--- /dev/null
+++ b/target/linux/kirkwood/patches-5.4/112-sheevaplug.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/boot/dts/kirkwood-sheevaplug-common.dtsi
++++ b/arch/arm/boot/dts/kirkwood-sheevaplug-common.dtsi
+@@ -78,13 +78,8 @@
+ };
+
+ partition@100000 {
+- label = "uImage";
+- reg = <0x0100000 0x400000>;
+- };
+-
+- partition@500000 {
+- label = "root";
+- reg = <0x0500000 0x1fb00000>;
++ label = "ubi";
++ reg = <0x0100000 0x1ff00000>;
+ };
+ };
+
+--- a/arch/arm/boot/dts/kirkwood-sheevaplug.dts
++++ b/arch/arm/boot/dts/kirkwood-sheevaplug.dts
+@@ -13,6 +13,13 @@
+ model = "Globalscale Technologies SheevaPlug";
+ compatible = "globalscale,sheevaplug", "marvell,kirkwood-88f6281", "marvell,kirkwood";
+
++ aliases {
++ led-boot = &led_health;
++ led-failsafe = &led_health;
++ led-running = &led_health;
++ led-upgrade = &led_health;
++ };
++
+ ocp@f1000000 {
+ mvsdio@90000 {
+ pinctrl-0 = <&pmx_sdio>;
+@@ -28,10 +35,10 @@
+ pinctrl-0 = <&pmx_led_blue &pmx_led_red>;
+ pinctrl-names = "default";
+
+- health {
++ led_health: health {
+ label = "sheevaplug:blue:health";
+ gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
+- default-state = "keep";
++ default-state = "on";
+ };
+
+ misc {