aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/bcm63xx/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/bcm63xx/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/bcm63xx/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/bcm63xx/dts/bcm6362-huawei-hg253s-v2.dts178
-rw-r--r--target/linux/bcm63xx/image/bcm63xx_nand.mk22
-rw-r--r--target/linux/bcm63xx/patches-5.4/566-board-HG253s-v2.patch56
6 files changed, 265 insertions, 0 deletions
diff --git a/target/linux/bcm63xx/base-files/etc/board.d/01_leds b/target/linux/bcm63xx/base-files/etc/board.d/01_leds
index 3b041be721..bfddcb69c4 100755
--- a/target/linux/bcm63xx/base-files/etc/board.d/01_leds
+++ b/target/linux/bcm63xx/base-files/etc/board.d/01_leds
@@ -50,6 +50,9 @@ huawei,echolife-hg622)
huawei,echolife-hg655b)
ucidef_set_led_usbdev "usb" "USB" "HW65x:green:usb" "1-2"
;;
+huawei,hg253s-v2)
+ ucidef_set_led_usbdev "usb" "USB" "hg253s-v2:green:usb" "1-1"
+ ;;
inventel,livebox-1)
ucidef_set_led_netdev "lan" "LAN" "Livebox1:red:traffic" "eth0"
ucidef_set_led_netdev "wan" "WAN" "Livebox1:red:adsl" "eth1"
diff --git a/target/linux/bcm63xx/base-files/etc/board.d/02_network b/target/linux/bcm63xx/base-files/etc/board.d/02_network
index 14eb1091f5..a3788adac2 100755
--- a/target/linux/bcm63xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm63xx/base-files/etc/board.d/02_network
@@ -120,6 +120,10 @@ sfr,neufbox-4-sercomm-r0)
ucidef_add_switch "switch0" \
"0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "5t@eth1"
;;
+huawei,hg253s-v2)
+ ucidef_add_switch "switch0" \
+ "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "8t@eth0"
+ ;;
inteno,vg50)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "8t@eth0"
diff --git a/target/linux/bcm63xx/base-files/lib/upgrade/platform.sh b/target/linux/bcm63xx/base-files/lib/upgrade/platform.sh
index 093eba056e..7d416297dd 100644
--- a/target/linux/bcm63xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/bcm63xx/base-files/lib/upgrade/platform.sh
@@ -7,6 +7,7 @@ platform_check_image() {
case "$(board_name)" in
comtrend,vg-8050|\
comtrend,vr-3032u|\
+ huawei,hg253s-v2|\
netgear,dgnd3700-v2|\
sercomm,ad1018)
# NAND sysupgrade
@@ -66,6 +67,7 @@ platform_do_upgrade() {
case "$(board_name)" in
comtrend,vg-8050|\
comtrend,vr-3032u|\
+ huawei,hg253s-v2|\
netgear,dgnd3700-v2|\
sercomm,ad1018)
REQUIRE_IMAGE_METADATA=1
diff --git a/target/linux/bcm63xx/dts/bcm6362-huawei-hg253s-v2.dts b/target/linux/bcm63xx/dts/bcm6362-huawei-hg253s-v2.dts
new file mode 100644
index 0000000000..6b6cbe4170
--- /dev/null
+++ b/target/linux/bcm63xx/dts/bcm6362-huawei-hg253s-v2.dts
@@ -0,0 +1,178 @@
+/dts-v1/;
+
+#include "bcm6362.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+ model = "Huawei HG253s v2";
+ compatible = "huawei,hg253s-v2", "brcm,bcm6362";
+
+ aliases {
+ led-boot = &led_phone_green;
+ led-failsafe = &led_phone_green;
+ led-upgrade = &led_phone_green;
+ };
+
+ chosen {
+ bootargs = "rootfstype=squashfs,ubifs noinitrd console=ttyS0,115200";
+ stdout-path = "serial0:115200n8";
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&pinctrl 24 1>;
+ linux,code = <KEY_RESTART>;
+ debounce-interval = <60>;
+ };
+
+ wlan {
+ label = "wlan";
+ gpios = <&pinctrl 25 1>;
+ linux,code = <KEY_WLAN>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&pinctrl 26 1>;
+ linux,code = <KEY_WPS_BUTTON>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_phone_green: led@28 {
+ label = "hg253s-v2:green:phone";
+ gpios = <&pinctrl 28 1>;
+ };
+
+ led@30 {
+ label = "hg253s-v2:green:usb";
+ gpios = <&pinctrl 30 1>;
+ };
+ };
+};
+
+&leds {
+ status = "ok";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_leds>;
+
+ led@3 {
+ reg = <3>;
+ active-low;
+ label = "hg253s-v2:green:internet";
+ };
+
+ led@5 {
+ reg = <5>;
+ active-low;
+ label = "hg253s-v2:green:wifi";
+ };
+};
+
+&lsspi {
+ switch@0 {
+ compatible = "brcm,bcm53125";
+ reg = <0>;
+ spi-max-frequency = <781000>;
+
+ lede,alias = "eth0";
+
+ ports {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ lan@1 {
+ reg = <1>;
+ label = "lan4";
+ };
+
+ lan@2 {
+ reg = <2>;
+ label = "lan3";
+ };
+
+ lan@3 {
+ reg = <3>;
+ label = "lan2";
+ };
+
+ lan@4 {
+ reg = <4>;
+ label = "lan1";
+ };
+
+ cpu@8 {
+ reg = <8>;
+ label = "cpu";
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ asym-pause;
+ pause;
+ };
+ };
+ };
+ };
+};
+
+&nflash {
+ status = "ok";
+
+ nandcs@0 {
+ compatible = "brcm,nandcs";
+ #size-cells = <1>;
+ #address-cells = <1>;
+ reg = <0>;
+ nand-ecc-step-size = <512>;
+ nand-ecc-strength = <15>;
+ nand-on-flash-bbt;
+ brcm,nand-oob-sector-size = <64>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "cferom";
+ reg = <0x0000000 0x0020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "brcm,wfi";
+ label = "wfi";
+ reg = <0x0020000 0x7d80000>;
+ };
+
+ partition@7da0000 {
+ label = "nvram";
+ reg = <0x7da0000 0x160000>;
+ };
+ };
+ };
+};
+
+&pinctrl {
+ pinctrl_leds: leds {
+ function = "led";
+ pins = "gpio3", "gpio5";
+ };
+};
+
+&uart0 {
+ status = "ok";
+};
diff --git a/target/linux/bcm63xx/image/bcm63xx_nand.mk b/target/linux/bcm63xx/image/bcm63xx_nand.mk
index c70fdf8b2f..5483c73077 100644
--- a/target/linux/bcm63xx/image/bcm63xx_nand.mk
+++ b/target/linux/bcm63xx/image/bcm63xx_nand.mk
@@ -71,6 +71,28 @@ define Device/comtrend_vg-8050
endef
TARGET_DEVICES += comtrend_vg-8050
+### Huawei ###
+define Device/huawei_hg253s-v2
+ $(Device/bcm63xx-nand)
+ IMAGES := flash.bin sysupgrade.bin
+ IMAGE/flash.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | cfe-jffs2-cferam | append-ubi
+ DEVICE_VENDOR := Huawei
+ DEVICE_MODEL := HG253s
+ DEVICE_VARIANT := v2
+ CHIP_ID := 6362
+ CFE_PART_FLAGS := 1
+ CFE_PART_ID := 0x0001EFEE
+ CFE_RAM_FILE := huawei,hg253s-v2/cferam.000
+ CFE_RAM_JFFS2_NAME := cferam.000
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 512
+ VID_HDR_OFFSET := 2048
+ DEVICE_PACKAGES += $(USB2_PACKAGES)
+ CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += huawei_hg253s-v2
+
### Netgear ###
define Device/netgear_dgnd3700-v2
$(Device/bcm63xx-nand)
diff --git a/target/linux/bcm63xx/patches-5.4/566-board-HG253s-v2.patch b/target/linux/bcm63xx/patches-5.4/566-board-HG253s-v2.patch
new file mode 100644
index 0000000000..cbcd2ade96
--- /dev/null
+++ b/target/linux/bcm63xx/patches-5.4/566-board-HG253s-v2.patch
@@ -0,0 +1,56 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -1879,6 +1879,37 @@ static struct board_info __initdata boar
+ },
+ },
+ };
++
++static struct board_info __initdata board_hg253s_v2 = {
++ .name = "hg253s",
++ .expected_cpu_id = 0x6362,
++
++ .has_ehci0 = 1,
++ .has_ohci0 = 1,
++ .num_usbh_ports = 1,
++
++ .has_enetsw = 1,
++ .enetsw = {
++ .used_ports = {
++ [4] = {
++ .used = 1,
++ .phy_id = 0xff,
++ .bypass_link = 1,
++ .force_speed = 1000,
++ .force_duplex_full = 1,
++ .timing_sel = 1,
++ .name = "RGMII",
++ },
++
++ [5] = {
++ .used = 1,
++ .phy_id = 24,
++ .timing_sel = 1,
++ .name = "WAN",
++ },
++ },
++ },
++};
+ #endif /* CONFIG_BCM63XX_CPU_6362 */
+
+ /*
+@@ -2882,6 +2913,7 @@ static const struct board_info __initcon
+ &board_nb6,
+ &board_dgnd3700v2,
+ &board_fast2504n,
++ &board_hg253s_v2,
+ #endif
+
+ #ifdef CONFIG_BCM63XX_CPU_6368
+@@ -2997,6 +3029,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "bt,home-hub-2-a", .data = &board_homehub2a, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6362
++ { .compatible = "huawei,hg253s-v2", .data = &board_hg253s_v2, },
+ { .compatible = "netgear,dgnd3700-v2", .data = &board_dgnd3700v2, },
+ { .compatible = "sagem,fast-2504n", .data = &board_fast2504n, },
+ { .compatible = "sfr,neufbox-6-sercomm-r0", .data = &board_nb6, },