aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/realtek/image/Makefile5
-rw-r--r--target/linux/realtek/image/common.mk21
2 files changed, 16 insertions, 10 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index f50821d24a..bb704ac863 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -6,6 +6,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80100000
DEVICE_VARS += \
+ CAMEO_BOARD_MODEL \
CAMEO_BOARD_VERSION \
CAMEO_CUSTOMER_SIGNATURE \
CAMEO_KERNEL_PART \
@@ -36,12 +37,12 @@ define Build/cameo-headers
dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
dd if=$@ bs=$(CAMEO_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
$(SCRIPT_DIR)/cameo-imghdr.py $@.kernel_part $@.kernel_part.hex \
- "$(DEVICE_MODEL)" os $(CAMEO_KERNEL_PART) \
+ "$(CAMEO_BOARD_MODEL)" os $(CAMEO_KERNEL_PART) \
$(CAMEO_CUSTOMER_SIGNATURE) \
$(CAMEO_BOARD_VERSION) \
$(KERNEL_LOADADDR); \
$(SCRIPT_DIR)/cameo-imghdr.py $@.rootfs_part $@.rootfs_part.hex \
- "$(DEVICE_MODEL)" squashfs $(CAMEO_ROOTFS_PART) \
+ "$(CAMEO_BOARD_MODEL)" squashfs $(CAMEO_ROOTFS_PART) \
$(CAMEO_CUSTOMER_SIGNATURE) \
$(CAMEO_BOARD_VERSION); \
cat $@.kernel_part.hex $@.rootfs_part.hex > $@
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
index 1a1d6356a7..37370f1999 100644
--- a/target/linux/realtek/image/common.mk
+++ b/target/linux/realtek/image/common.mk
@@ -1,19 +1,13 @@
# SPDX-License-Identifier: GPL-2.0-only
-define Device/d-link_dgs-1210
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
- DLINK_KERNEL_PART_SIZE := 1572864
+define Device/cameo-fw
+ CAMEO_BOARD_MODEL = $$(DEVICE_MODEL)
KERNEL := \
kernel-bin | \
append-dtb | \
libdeflate-gzip | \
uImage gzip | \
cameo-tag
- CAMEO_KERNEL_PART := 2
- CAMEO_ROOTFS_PART := 3
- CAMEO_CUSTOMER_SIGNATURE := 2
- CAMEO_BOARD_VERSION := 32
IMAGES += factory_image1.bin
IMAGE/factory_image1.bin := \
append-kernel | \
@@ -26,6 +20,17 @@ define Device/d-link_dgs-1210
cameo-headers
endef
+define Device/d-link_dgs-1210
+ $(Device/cameo-fw)
+ IMAGE_SIZE := 13824k
+ DEVICE_VENDOR := D-Link
+ CAMEO_KERNEL_PART_SIZE := 1572864
+ CAMEO_KERNEL_PART := 2
+ CAMEO_ROOTFS_PART := 3
+ CAMEO_CUSTOMER_SIGNATURE := 2
+ CAMEO_BOARD_VERSION := 32
+endef
+
define Device/hpe_1920
DEVICE_VENDOR := HPE
IMAGE_SIZE := 29632k