aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0446-nvmem-Add-driver-to-expose-reserved-memory-as-nvmem.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0446-nvmem-Add-driver-to-expose-reserved-memory-as-nvmem.patch b/target/linux/bcm27xx/patches-5.10/950-0446-nvmem-Add-driver-to-expose-reserved-memory-as-nvmem.patch
index 79fc84f5ac..bf2e4791fa 100644
--- a/target/linux/bcm27xx/patches-5.10/950-0446-nvmem-Add-driver-to-expose-reserved-memory-as-nvmem.patch
+++ b/target/linux/bcm27xx/patches-5.10/950-0446-nvmem-Add-driver-to-expose-reserved-memory-as-nvmem.patch
@@ -30,9 +30,9 @@ Changes since v1:
--- a/drivers/nvmem/Kconfig
+++ b/drivers/nvmem/Kconfig
-@@ -270,4 +270,12 @@ config SPRD_EFUSE
- This driver can also be built as a module. If so, the module
- will be called nvmem-sprd-efuse.
+@@ -283,4 +283,13 @@ config NVMEM_U_BOOT_ENV
+
+ If compiled as module it will be called nvmem_u-boot-env.
+config NVMEM_RMEM
+ tristate "Reserved Memory Based Driver Support"
@@ -42,13 +42,14 @@ Changes since v1:
+
+ This driver can also be built as a module. If so, the module
+ will be called nvmem-rmem.
++
endif
--- a/drivers/nvmem/Makefile
+++ b/drivers/nvmem/Makefile
-@@ -55,3 +55,5 @@ obj-$(CONFIG_NVMEM_ZYNQMP) += nvmem_zynq
- nvmem_zynqmp_nvmem-y := zynqmp_nvmem.o
- obj-$(CONFIG_SPRD_EFUSE) += nvmem_sprd_efuse.o
+@@ -57,3 +57,5 @@ obj-$(CONFIG_SPRD_EFUSE) += nvmem_sprd_e
nvmem_sprd_efuse-y := sprd-efuse.o
+ obj-$(CONFIG_NVMEM_U_BOOT_ENV) += nvmem_u-boot-env.o
+ nvmem_u-boot-env-y := u-boot-env.o
+obj-$(CONFIG_NVMEM_RMEM) += nvmem-rmem.o
+nvmem-rmem-y := rmem.o
--- /dev/null