aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86-2.6/image/Makefile')
-rw-r--r--target/linux/x86-2.6/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/Makefile b/target/linux/x86-2.6/image/Makefile
index e1425676dd..44c2ff7e3b 100644
--- a/target/linux/x86-2.6/image/Makefile
+++ b/target/linux/x86-2.6/image/Makefile
@@ -49,10 +49,14 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
endif
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
+endef
+
define Image/Build
$(call Image/Build/grub,$(1))
cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
- cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+ cp $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
endef
$(eval $(call BuildImage))