aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/modules.mk')
-rw-r--r--target/linux/sunxi/modules.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 1a54677046..9a4782ddf2 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -54,3 +54,15 @@ define KernelPackage/ata-sunxi/description
endef
$(eval $(call KernelPackage,ata-sunxi))
+
+define KernelPackage/sun4i-emac
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=AllWinner EMAC Ethernet support
+ DEPENDS:=@TARGET_sunxi
+ KCONFIG:=CONFIG_SUN4I_EMAC
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/allwinner/sun4i-emac.ko
+ AUTOLOAD:=$(call AutoProbe,sun4i-emac)
+endef
+
+$(eval $(call KernelPackage,sun4i-emac))
+