aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sibyte/patches/106-no_module_reloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sibyte/patches/106-no_module_reloc.patch')
-rw-r--r--target/linux/sibyte/patches/106-no_module_reloc.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/sibyte/patches/106-no_module_reloc.patch b/target/linux/sibyte/patches/106-no_module_reloc.patch
index 3b1f12427a..108b498088 100644
--- a/target/linux/sibyte/patches/106-no_module_reloc.patch
+++ b/target/linux/sibyte/patches/106-no_module_reloc.patch
@@ -1,11 +1,13 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -85,7 +85,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
+@@ -93,8 +93,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
--MODFLAGS += -mno-long-calls
-+MODFLAGS += -mlong-calls
+-KBUILD_AFLAGS_MODULE += -mno-long-calls
+-KBUILD_CFLAGS_MODULE += -mno-long-calls
++KBUILD_AFLAGS_MODULE += -mlong-calls
++KBUILD_CFLAGS_MODULE += -mlong-calls
cflags-y += -ffreestanding