aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/samsung/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/samsung/Makefile')
-rw-r--r--target/linux/samsung/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/samsung/Makefile b/target/linux/samsung/Makefile
new file mode 100644
index 0000000000..9227503096
--- /dev/null
+++ b/target/linux/samsung/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2018 Jianhui Zhao <jianhuizhao329@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=samsung
+BOARDNAME:=Samsung s3c24xx/s5pv210
+SUBTARGETS:=s5pv210
+MAINTAINER:=Jianhui Zhao <jianhuizhao329@gmail.com>
+
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+ Build firmware images for Samsung s3c24xx/s5pv210 based boards.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
+
+$(eval $(call BuildTarget))