aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/patches-5.4
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rtl838x/patches-5.4')
-rw-r--r--target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch2
-rw-r--r--target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch4
-rw-r--r--target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch2
-rw-r--r--target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch6
-rw-r--r--target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch2
-rw-r--r--target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch6
6 files changed, 10 insertions, 12 deletions
diff --git a/target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch b/target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch
index 34fb959a50..ec114a04c9 100644
--- a/target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/rtl838x/patches-5.4/300-mips-add-rtl838x-platform.patch
@@ -10,7 +10,7 @@
platforms += sgi-ip27
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -629,6 +629,29 @@ config RALINK
+@@ -630,6 +630,29 @@ config RALINK
select ARCH_HAS_RESET_CONTROLLER
select RESET_CONTROLLER
diff --git a/target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch b/target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch
index 5eb8521ccb..f911e5158b 100644
--- a/target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch
+++ b/target/linux/rtl838x/patches-5.4/301-gpio-add-rtl838x-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
-@@ -441,6 +441,12 @@
+@@ -441,6 +441,12 @@ config GPIO_REG
A 32-bit single register GPIO fixed in/out implementation. This
can be used to represent any register as a set of GPIO signals.
@@ -15,7 +15,7 @@
depends on MFD_SYSCON
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
-@@ -117,6 +117,7 @@
+@@ -117,6 +117,7 @@ obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t
obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
obj-$(CONFIG_GPIO_REG) += gpio-reg.o
diff --git a/target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
index 0082176d83..7dd12b7917 100644
--- a/target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
+++ b/target/linux/rtl838x/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/dsa/Kconfig
+++ b/drivers/net/dsa/Kconfig
-@@ -74,6 +74,13 @@ config NET_DSA_REALTEK_SMI
+@@ -75,6 +75,13 @@ config NET_DSA_REALTEK_SMI
This enables support for the Realtek SMI-based switch
chips, currently only RTL8366RB.
diff --git a/target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch b/target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
index 5329dcad59..929f2b9444 100644
--- a/target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
+++ b/target/linux/rtl838x/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.24/include/linux/platform_data/dsa.h
-===================================================================
---- linux-5.4.24.orig/include/linux/platform_data/dsa.h
-+++ linux-5.4.24/include/linux/platform_data/dsa.h
+--- a/include/linux/platform_data/dsa.h
++++ b/include/linux/platform_data/dsa.h
@@ -6,7 +6,7 @@ struct device;
struct net_device;
diff --git a/target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch b/target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
index db8b0403f7..c61b5f6fff 100644
--- a/target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
+++ b/target/linux/rtl838x/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -628,6 +628,10 @@
+@@ -650,6 +650,10 @@ struct phy_driver {
struct ethtool_tunable *tuna,
const void *data);
int (*set_loopback)(struct phy_device *dev, bool enable);
diff --git a/target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch b/target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch
index 5262be53c6..7743147ea3 100644
--- a/target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch
+++ b/target/linux/rtl838x/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/phylink.c
+++ b/drivers/net/phy/phylink.c
-@@ -1244,6 +1244,11 @@
+@@ -1242,6 +1242,11 @@ int phylink_ethtool_ksettings_set(struct
/* If we have a PHY, configure the phy */
if (pl->phydev) {
@@ -12,7 +12,7 @@
ret = phy_ethtool_ksettings_set(pl->phydev, &our_kset);
if (ret)
return ret;
-@@ -1422,8 +1427,11 @@
+@@ -1420,8 +1425,11 @@ int phylink_ethtool_get_eee(struct phyli
ASSERT_RTNL();
@@ -25,7 +25,7 @@
return ret;
}
-@@ -1440,9 +1448,11 @@
+@@ -1438,9 +1446,11 @@ int phylink_ethtool_set_eee(struct phyli
ASSERT_RTNL();