aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch12
-rw-r--r--target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch12
-rw-r--r--target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch6
-rw-r--r--target/linux/realtek/patches-5.4/705-add-rtl-phy.patch6
-rw-r--r--target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch2
5 files changed, 13 insertions, 25 deletions
diff --git a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
index 2c4f062792..e946a5b1a0 100644
--- a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/arch/mips/Kbuild.platforms
-===================================================================
---- linux-5.4.77.orig/arch/mips/Kbuild.platforms
-+++ linux-5.4.77/arch/mips/Kbuild.platforms
+--- a/arch/mips/Kbuild.platforms
++++ b/arch/mips/Kbuild.platforms
@@ -27,6 +27,7 @@ platforms += pistachio
platforms += pmcs-msp71xx
platforms += pnx833x
@@ -10,10 +8,8 @@ Index: linux-5.4.77/arch/mips/Kbuild.platforms
platforms += rb532
platforms += sgi-ip22
platforms += sgi-ip27
-Index: linux-5.4.77/arch/mips/Kconfig
-===================================================================
---- linux-5.4.77.orig/arch/mips/Kconfig
-+++ linux-5.4.77/arch/mips/Kconfig
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
@@ -630,6 +630,26 @@ config RALINK
select ARCH_HAS_RESET_CONTROLLER
select RESET_CONTROLLER
diff --git a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
index 20602076b2..bb6f83e55d 100644
--- a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
+++ b/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/drivers/net/dsa/Kconfig
-===================================================================
---- linux-5.4.77.orig/drivers/net/dsa/Kconfig
-+++ linux-5.4.77/drivers/net/dsa/Kconfig
+--- a/drivers/net/dsa/Kconfig
++++ b/drivers/net/dsa/Kconfig
@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
This enables support for the Qualcomm Atheros QCA8K Ethernet
switch chips.
@@ -11,10 +9,8 @@ Index: linux-5.4.77/drivers/net/dsa/Kconfig
config NET_DSA_REALTEK_SMI
tristate "Realtek SMI Ethernet switch family support"
depends on NET_DSA
-Index: linux-5.4.77/drivers/net/dsa/Makefile
-===================================================================
---- linux-5.4.77.orig/drivers/net/dsa/Makefile
-+++ linux-5.4.77/drivers/net/dsa/Makefile
+--- a/drivers/net/dsa/Makefile
++++ b/drivers/net/dsa/Makefile
@@ -21,3 +21,4 @@ obj-y += b53/
obj-y += microchip/
obj-y += mv88e6xxx/
diff --git a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
index 9d4140c8e1..c8a09c50d3 100644
--- a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
+++ b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/net/dsa/tag_trailer.c
-===================================================================
---- linux-5.4.77.orig/net/dsa/tag_trailer.c
-+++ linux-5.4.77/net/dsa/tag_trailer.c
+--- a/net/dsa/tag_trailer.c
++++ b/net/dsa/tag_trailer.c
@@ -44,7 +44,12 @@ static struct sk_buff *trailer_xmit(stru
trailer = skb_put(nskb, 4);
diff --git a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
index 5c5d08fe9f..826891abe1 100644
--- a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
+++ b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/drivers/net/phy/Makefile
-===================================================================
---- linux-5.4.77.orig/drivers/net/phy/Makefile
-+++ linux-5.4.77/drivers/net/phy/Makefile
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
@@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc.o
obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
diff --git a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch b/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
index c74f78b0b0..ca6deb74d8 100644
--- a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
+++ b/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -188,7 +188,7 @@
+@@ -188,7 +188,7 @@ static inline const char *phy_modes(phy_
#define PHY_INIT_TIMEOUT 100000
#define PHY_FORCE_TIMEOUT 10