aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch')
-rw-r--r--target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch b/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
new file mode 100644
index 0000000000..16cff75308
--- /dev/null
+++ b/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/spi-nor/Kconfig
++++ b/drivers/mtd/spi-nor/Kconfig
+@@ -118,4 +118,13 @@ config SPI_INTEL_SPI_PLATFORM
+ To compile this driver as a module, choose M here: the module
+ will be called intel-spi-platform.
+
++config SPI_RTL838X
++ tristate "Realtek RTl838X SPI flash platform driver"
++ depends on RTL838X
++ help
++ This driver provides support for accessing SPI flash
++ in the RTL838X SoC.
++
++ Say N here unless you know what you are doing.
++
+ endif # MTD_SPI_NOR
+--- a/drivers/mtd/spi-nor/Makefile
++++ b/drivers/mtd/spi-nor/Makefile
+@@ -8,3 +8,4 @@ obj-$(CONFIG_SPI_NXP_SPIFI) += nxp-spifi
+ obj-$(CONFIG_SPI_INTEL_SPI) += intel-spi.o
+ obj-$(CONFIG_SPI_INTEL_SPI_PCI) += intel-spi-pci.o
+ obj-$(CONFIG_SPI_INTEL_SPI_PLATFORM) += intel-spi-platform.o
++obj-$(CONFIG_SPI_RTL838X) += rtl838x-nor.o