aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches/100-rb5xx_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rb532/patches/100-rb5xx_support.patch')
-rw-r--r--target/linux/rb532/patches/100-rb5xx_support.patch52
1 files changed, 29 insertions, 23 deletions
diff --git a/target/linux/rb532/patches/100-rb5xx_support.patch b/target/linux/rb532/patches/100-rb5xx_support.patch
index 3bb6aaa8c3..262ea61e15 100644
--- a/target/linux/rb532/patches/100-rb5xx_support.patch
+++ b/target/linux/rb532/patches/100-rb5xx_support.patch
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.23.12/arch/mips/Kconfig linux-2.6.23.12.new/arch/mips/Kconfig
---- linux-2.6.23.12/arch/mips/Kconfig 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/arch/mips/Kconfig 2008-01-11 08:46:20.000000000 +0100
-@@ -595,6 +595,20 @@
+Index: linux-2.6.23.17/arch/mips/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/arch/mips/Kconfig
++++ linux-2.6.23.17/arch/mips/Kconfig
+@@ -595,6 +595,20 @@ config WR_PPMC
This enables support for the Wind River MIPS32 4KC PPMC evaluation
board, which is based on GT64120 bridge chip.
@@ -22,7 +23,7 @@ diff -urN linux-2.6.23.12/arch/mips/Kconfig linux-2.6.23.12.new/arch/mips/Kconfi
endchoice
source "arch/mips/au1000/Kconfig"
-@@ -829,6 +843,7 @@
+@@ -829,6 +843,7 @@ config MIPS_L1_CACHE_SHIFT
default "4" if MACH_DECSTATION
default "7" if SGI_IP27 || SNI_RM
default "4" if PMC_MSP4200_EVAL
@@ -30,10 +31,11 @@ diff -urN linux-2.6.23.12/arch/mips/Kconfig linux-2.6.23.12.new/arch/mips/Kconfi
default "5"
config HAVE_STD_PC_SERIAL_PORT
-diff -urN linux-2.6.23.12/arch/mips/Makefile linux-2.6.23.12.new/arch/mips/Makefile
---- linux-2.6.23.12/arch/mips/Makefile 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/arch/mips/Makefile 2008-01-11 08:47:04.000000000 +0100
-@@ -300,6 +300,13 @@
+Index: linux-2.6.23.17/arch/mips/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/arch/mips/Makefile
++++ linux-2.6.23.17/arch/mips/Makefile
+@@ -300,6 +300,13 @@ load-$(CONFIG_LEMOTE_FULONG) +=0xfffffff
cflags-$(CONFIG_LEMOTE_FULONG) += -Iinclude/asm-mips/mach-lemote
#
@@ -47,18 +49,20 @@ diff -urN linux-2.6.23.12/arch/mips/Makefile linux-2.6.23.12.new/arch/mips/Makef
# For all MIPS, Inc. eval boards
#
core-$(CONFIG_MIPS_BOARDS_GEN) += arch/mips/mips-boards/generic/
-diff -urN linux-2.6.23.12/arch/mips/pci/Makefile linux-2.6.23.12.new/arch/mips/pci/Makefile
---- linux-2.6.23.12/arch/mips/pci/Makefile 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/arch/mips/pci/Makefile 2008-01-11 08:47:30.000000000 +0100
-@@ -46,3 +46,4 @@
+Index: linux-2.6.23.17/arch/mips/pci/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/arch/mips/pci/Makefile
++++ linux-2.6.23.17/arch/mips/pci/Makefile
+@@ -46,3 +46,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_MIKROTIK_RB500) += pci-rc32434.o ops-rc32434.o fixup-rb500.o
-diff -urN linux-2.6.23.12/drivers/pci/Makefile linux-2.6.23.12.new/drivers/pci/Makefile
---- linux-2.6.23.12/drivers/pci/Makefile 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/drivers/pci/Makefile 2008-01-11 08:48:10.000000000 +0100
-@@ -32,6 +32,7 @@
+Index: linux-2.6.23.17/drivers/pci/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/pci/Makefile
++++ linux-2.6.23.17/drivers/pci/Makefile
+@@ -32,6 +32,7 @@ obj-$(CONFIG_PPC32) += setup-irq.o
obj-$(CONFIG_PPC64) += setup-bus.o
obj-$(CONFIG_MIPS) += setup-bus.o setup-irq.o
obj-$(CONFIG_X86_VISWS) += setup-irq.o
@@ -66,9 +70,10 @@ diff -urN linux-2.6.23.12/drivers/pci/Makefile linux-2.6.23.12.new/drivers/pci/M
#
# ACPI Related PCI FW Functions
-diff -urN linux-2.6.23.12/include/asm-mips/bootinfo.h linux-2.6.23.12.new/include/asm-mips/bootinfo.h
---- linux-2.6.23.12/include/asm-mips/bootinfo.h 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/include/asm-mips/bootinfo.h 2008-01-11 08:48:48.000000000 +0100
+Index: linux-2.6.23.17/include/asm-mips/bootinfo.h
+===================================================================
+--- linux-2.6.23.17.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.23.17/include/asm-mips/bootinfo.h
@@ -208,6 +208,11 @@
#define MACH_GROUP_WINDRIVER 28 /* Windriver boards */
#define MACH_WRPPMC 1
@@ -81,9 +86,10 @@ diff -urN linux-2.6.23.12/include/asm-mips/bootinfo.h linux-2.6.23.12.new/includ
#define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void);
-diff -urN linux-2.6.23.12/include/asm-mips/cpu.h linux-2.6.23.12.new/include/asm-mips/cpu.h
---- linux-2.6.23.12/include/asm-mips/cpu.h 2007-12-18 22:55:57.000000000 +0100
-+++ linux-2.6.23.12.new/include/asm-mips/cpu.h 2008-01-11 08:49:34.000000000 +0100
+Index: linux-2.6.23.17/include/asm-mips/cpu.h
+===================================================================
+--- linux-2.6.23.17.orig/include/asm-mips/cpu.h
++++ linux-2.6.23.17/include/asm-mips/cpu.h
@@ -217,8 +217,9 @@
#define CPU_R14000 64
#define CPU_LOONGSON1 65