aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7628an_linksys_e5400.dts163
-rw-r--r--target/linux/ramips/image/mt76x8.mk15
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/02_network7
3 files changed, 185 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7628an_linksys_e5400.dts b/target/linux/ramips/dts/mt7628an_linksys_e5400.dts
new file mode 100644
index 0000000000..3a6403fe7f
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_linksys_e5400.dts
@@ -0,0 +1,163 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "linksys,e5400", "mediatek,mt7628an-soc";
+ model = "Linksys E5400";
+
+ aliases {
+ led-boot = &led_wps;
+ led-failsafe = &led_wps;
+ led-running = &led_wps;
+ led-upgrade = &led_wps;
+ label-mac-device = &ethernet;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x4000000>;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_wps: wps {
+ label = "green:wps";
+ gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_28: macaddr@28 {
+ reg = <0x28 0x6>;
+ };
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfa0000>;
+ };
+
+ partition@ff0000 {
+ label = "cbtinfo";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&ehci {
+ status = "disabled";
+};
+
+&esw {
+ mediatek,portmap = <0x2f>;
+ mediatek,portdisable = <0x20>;
+};
+
+&ethernet {
+ nvmem-cells = <&macaddr_factory_28>;
+ nvmem-cell-names = "mac-address";
+};
+
+&ohci {
+ status = "disabled";
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi5: wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+
+ nvmem-cells = <&macaddr_factory_28>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <3>;
+ };
+};
+
+&state_default {
+ gpio {
+ group = "gpio", "i2c", "i2s", "refclk", "uart1", "wdt", "wled_an";
+ function = "gpio";
+ };
+};
+
+&usbphy {
+ status = "disabled";
+};
+
+&wmac {
+ status = "okay";
+
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ nvmem-cells = <&macaddr_factory_28>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <2>;
+};
+
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 1b7e786b52..a77f1c97e1 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -342,6 +342,21 @@ define Device/kroks_kndrt31r19
endef
TARGET_DEVICES += kroks_kndrt31r19
+define Device/linksys_e5400
+ IMAGE_SIZE := 16000k
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := E5400
+ DEVICE_ALT0_VENDOR := Linksys
+ DEVICE_ALT0_MODEL := E2500
+ DEVICE_ALT0_VARIANT := v4
+ DEVICE_ALT1_VENDOR := Linksys
+ DEVICE_ALT1_MODEL := E5300
+ DEVICE_ALT2_VENDOR := Linksys
+ DEVICE_ALT2_MODEL := E5350
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += linksys_e5400
+
define Device/mediatek_linkit-smart-7688
IMAGE_SIZE := 32448k
DEVICE_VENDOR := MediaTek
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index d85cdf3db7..26415e0fa6 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -125,6 +125,10 @@ ramips_setup_interfaces()
ucidef_set_interface_lan "eth0"
ucidef_set_interface "wan" device "/dev/cdc-wdm0" protocol "qmi"
;;
+ linksys,e5400)
+ ucidef_add_switch "switch0" \
+ "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan" "6@eth0"
+ ;;
motorola,mwr03)
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "3:lan" "0:wan" "6@eth0"
@@ -248,6 +252,9 @@ ramips_setup_macs()
totolink,lr1200)
wan_mac=$(mtd_get_mac_binary factory 0x2e)
;;
+ linksys,e5400)
+ wan_mac=$(mtd_get_mac_binary factory 0x22)
+ ;;
mercury,mac1200r-v2)
wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory_info 0xd)" 1)
;;