aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ramips/dts/AP-MTKH7-0006.dts111
-rw-r--r--target/linux/ramips/dts/WIO-ONE.dts130
-rw-r--r--target/linux/ramips/image/mt7621.mk21
-rw-r--r--target/linux/ramips/mt7621/config-4.142
5 files changed, 0 insertions, 269 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index be0accda89..ca111c9d4c 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -415,7 +415,6 @@ ramips_setup_interfaces()
"0:lan:3" "1:lan:2" "2:lan:1" "3:wan" "6@eth0"
;;
planex,mzk-dp150n|\
- sge,ap-mtkh7-0006|\
vocore,vocore-8m|\
vocore,vocore-16m)
ucidef_add_switch "switch0" \
@@ -453,10 +452,6 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "2:lan" "6t@eth0"
;;
- wio,wio-one)
- ucidef_add_switch "switch0" \
- "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan" "6@eth0"
- ;;
wiznet,wizfi630a)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:wan" "6@eth0"
diff --git a/target/linux/ramips/dts/AP-MTKH7-0006.dts b/target/linux/ramips/dts/AP-MTKH7-0006.dts
deleted file mode 100644
index 5ab57b2eec..0000000000
--- a/target/linux/ramips/dts/AP-MTKH7-0006.dts
+++ /dev/null
@@ -1,111 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
- compatible = "sge,ap-mtkh7-0006", "mediatek,mt7621-soc";
- model = "SGE AP-MTKH7-0006";
-
- chosen {
- bootargs = "console=ttyS0,57600";
- };
-
- wdt@18 {
- status = "okay";
- compatible = "linux,wdt-gpio";
-
- always-running;
- hw_algo = "level";
- hw_margin_ms = <60000>;
- gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
- };
-};
-
-&wdt {
- status = "disabled";
-};
-
-&spi0 {
- status = "okay";
-
- m25p80@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <10000000>;
- m25p,chunked-io = <32>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0x7b0000>;
- };
-
- partition@850000 {
- label = "firmware2";
- reg = <0x850000 0x7b0000>;
- };
- };
- };
-};
-
-&ethernet {
- mtd-mac-address = <&factory 4>;
- mtd-mac-address-increment = <(-2)>;
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "i2c", "uart2", "uart3", "rgmii2", "sdhci", "wdt";
- ralink,function = "gpio";
- };
- };
-};
-
-&pcie {
- status = "okay";
-};
-
-&pcie0 {
- mt76@0,0 {
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&factory 0x8000>;
- ieee80211-freq-limit = <5000000 6000000>;
- };
-};
-
-&pcie1 {
- mt76@0,0 {
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&factory 0x0000>;
- };
-};
-
-&xhci {
- status = "disabled";
-};
diff --git a/target/linux/ramips/dts/WIO-ONE.dts b/target/linux/ramips/dts/WIO-ONE.dts
deleted file mode 100644
index e470535b38..0000000000
--- a/target/linux/ramips/dts/WIO-ONE.dts
+++ /dev/null
@@ -1,130 +0,0 @@
-/dts-v1/;
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
- compatible = "wio,wio-one", "mediatek,mt7621-soc";
- model = "WIO ONE";
-
- aliases {
- led-boot = &led_power;
- led-failsafe = &led_power;
- led-running = &led_power;
- led-upgrade = &led_power;
- };
-
- chosen {
- bootargs = "console=ttyS0,57600";
- };
-
- gpio-leds {
- compatible = "gpio-leds";
-
- led_power: power {
- label = "wio-one:green:power";
- gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
- };
-
- alarm {
- label = "wio-one:red:alarm";
- gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
- };
- };
-
- gpio_export {
- compatible = "gpio-export";
- #size-cells = <0>;
-
- usb_power {
- gpio-export,name = "usb";
- gpio-export,output = <1>;
- gpios = <&gpio0 17 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&spi0 {
- status = "okay";
-
- m25p80@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <104000000>;
- m25p,fast-read;
- m25p,chunked-io = <32>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "u-boot-env";
- reg = <0x30000 0x10000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "factory";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0xfb0000>;
- compatible = "denx,uimage";
- };
- };
- };
-};
-
-&ethernet {
- mtd-mac-address = <&factory 4>;
- mtd-mac-address-increment = <(-2)>;
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "i2c", "uart2", "uart3", "rgmii2", "sdhci", "jtag";
- ralink,function = "gpio";
- };
- };
-};
-
-&pcie {
- status = "okay";
-};
-
-&pcie0 {
- mt76@0,0 {
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&factory 0x8000>;
- ieee80211-freq-limit = <5000000 6000000>;
- adant,sas-devid = <1>;
- adant,sas-gpio = <45 46 47 48>;
- };
-};
-
-&pcie1 {
- mt76@0,0 {
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&factory 0x0000>;
- adant,sas-devid = <0>;
- adant,sas-gpio = <41 42 43 44>;
- };
-};
-
-&xhci {
- status = "disabled";
-};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 15fdcbde05..d32feb7eab 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -685,27 +685,6 @@ define Device/xzwifi_creativebox-v1
endef
TARGET_DEVICES += xzwifi_creativebox-v1
-define Device/ap-mtkh7-0006
- DTS := AP-MTKH7-0006
- IMAGE_SIZE := $(ralink_default_fw_size_32M)
- SUPPORTED_DEVICES := sge,ap-mtkh7-0006
- DEVICE_TITLE := SGE AP-MTKH7-0006
- DEVICE_PACKAGES := \
- kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
- kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
-endef
-TARGET_DEVICES += ap-mtkh7-0006
-
-define Device/wio-one
- DTS := WIO-ONE
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
- SUPPORTED_DEVICES := wio,wio-one
- DEVICE_TITLE := WIO ONE
- DEVICE_PACKAGES := \
- kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-mini
-endef
-TARGET_DEVICES += wio-one
-
define Device/youhua_wr1200js
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
diff --git a/target/linux/ramips/mt7621/config-4.14 b/target/linux/ramips/mt7621/config-4.14
index 61aadb3ee2..a2c58e030b 100644
--- a/target/linux/ramips/mt7621/config-4.14
+++ b/target/linux/ramips/mt7621/config-4.14
@@ -91,8 +91,6 @@ CONFIG_GPIOLIB=y
CONFIG_GPIO_MT7621=y
# CONFIG_GPIO_RALINK is not set
CONFIG_GPIO_SYSFS=y
-CONFIG_GPIO_WATCHDOG=y
-CONFIG_GPIO_WATCHDOG_ARCH_INITCALL=y
# CONFIG_GRO_CELLS is not set
CONFIG_HANDLE_DOMAIN_IRQ=y
CONFIG_HARDWARE_WATCHPOINTS=y