aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/patches-4.9/0090-ethernet.patch4
-rw-r--r--target/linux/ramips/patches-4.9/0099-pci-mt7620.patch2
-rw-r--r--target/linux/ramips/patches-4.9/0100-prom_fixes.patch4
-rw-r--r--target/linux/ramips/patches-4.9/301-fix-rt3883.patch4
4 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ramips/patches-4.9/0090-ethernet.patch b/target/linux/ramips/patches-4.9/0090-ethernet.patch
index af8ae0b030..b163d59d20 100644
--- a/target/linux/ramips/patches-4.9/0090-ethernet.patch
+++ b/target/linux/ramips/patches-4.9/0090-ethernet.patch
@@ -19,7 +19,7 @@ Signed-off-by: Michael Lee <igvtee@gmail.com>
--- a/drivers/net/ethernet/Kconfig
+++ b/drivers/net/ethernet/Kconfig
-@@ -107,7 +107,7 @@
+@@ -107,7 +107,7 @@ config LANTIQ_ETOP
Support for the MII0 inside the Lantiq SoC
source "drivers/net/ethernet/marvell/Kconfig"
@@ -30,7 +30,7 @@ Signed-off-by: Michael Lee <igvtee@gmail.com>
source "drivers/net/ethernet/microchip/Kconfig"
--- a/drivers/net/ethernet/Makefile
+++ b/drivers/net/ethernet/Makefile
-@@ -47,7 +47,7 @@
+@@ -47,7 +47,7 @@ obj-$(CONFIG_JME) += jme.o
obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_LANTIQ_ETOP) += lantiq_etop.o
obj-$(CONFIG_NET_VENDOR_MARVELL) += marvell/
diff --git a/target/linux/ramips/patches-4.9/0099-pci-mt7620.patch b/target/linux/ramips/patches-4.9/0099-pci-mt7620.patch
index d2d8eeb833..f532f30db8 100644
--- a/target/linux/ramips/patches-4.9/0099-pci-mt7620.patch
+++ b/target/linux/ramips/patches-4.9/0099-pci-mt7620.patch
@@ -8,7 +8,7 @@
#define PPLL_DRV 0xa0
#define PDRV_SW_SET (1<<31)
-@@ -121,7 +120,7 @@
+@@ -121,7 +120,7 @@ static int wait_pciephy_busy(void)
else
break;
if (retry++ > WAITRETRY_MAX) {
diff --git a/target/linux/ramips/patches-4.9/0100-prom_fixes.patch b/target/linux/ramips/patches-4.9/0100-prom_fixes.patch
index 50eeeea219..07042f89b1 100644
--- a/target/linux/ramips/patches-4.9/0100-prom_fixes.patch
+++ b/target/linux/ramips/patches-4.9/0100-prom_fixes.patch
@@ -50,8 +50,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ if (chosen_dtb)
+ strlcpy(arcs_cmdline, boot_command_line, COMMAND_LINE_SIZE);
- of_scan_flat_dt(early_init_dt_find_memory, NULL);
- if (memory_dtb)
+ strlcpy(arcs_cmdline, boot_command_line, COMMAND_LINE_SIZE);
+
--- a/arch/mips/kernel/head.S
+++ b/arch/mips/kernel/head.S
@@ -85,6 +85,9 @@ EXPORT(__image_cmdline)
diff --git a/target/linux/ramips/patches-4.9/301-fix-rt3883.patch b/target/linux/ramips/patches-4.9/301-fix-rt3883.patch
index 100dd6253d..49a17cf964 100644
--- a/target/linux/ramips/patches-4.9/301-fix-rt3883.patch
+++ b/target/linux/ramips/patches-4.9/301-fix-rt3883.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ralink/rt3883.c
+++ b/arch/mips/ralink/rt3883.c
-@@ -63,16 +63,6 @@
+@@ -63,16 +63,6 @@ static struct rt2880_pmx_group rt3883_pi
{ 0 }
};
@@ -17,7 +17,7 @@
void __init ralink_clk_init(void)
{
unsigned long cpu_rate, sys_rate;
-@@ -157,5 +147,5 @@
+@@ -157,5 +147,5 @@ void prom_soc_init(struct ralink_soc_inf
rt2880_pinmux_data = rt3883_pinmux_data;