aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b6499c8806..325e3104a7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -472,6 +472,18 @@ define Device/tiny-ac
endef
TARGET_DEVICES += tiny-ac
+define Device/tplink_c2-v1
+ $(Device/Archer)
+ DTS := ArcherC2-v1
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0xc7500001
+ TPLINK_HWREV := 50
+ IMAGES += factory.bin
+ DEVICE_TITLE := TP-Link Archer C2 v1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
+endef
+TARGET_DEVICES += tplink_c2-v1
+
define Device/tplink_c20-v1
$(Device/Archer)
DTS := ArcherC20v1