aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorFranz Flasch <franz.flasch@gmx.at>2018-05-17 11:57:00 +0200
committerMathias Kresin <dev@kresin.me>2018-06-25 20:52:18 +0200
commit8375623a064037bbdd914bd9e7529eefa7172560 (patch)
treea421512693dc16efa1fc642a378184db41606d6e /target/linux/ramips/image
parentabb7524683cbc0185ee2d0b590c045065de354b7 (diff)
downloadupstream-8375623a064037bbdd914bd9e7529eefa7172560.tar.gz
upstream-8375623a064037bbdd914bd9e7529eefa7172560.tar.bz2
upstream-8375623a064037bbdd914bd9e7529eefa7172560.zip
ramips: add support for TP-Link Archer C2
Specification: - System-On-Chip: MT7620A - CPU/Speed: 580 MHz - Flash-Chip: Winbond 25Q64BVSIG - Flash size: 8192 KiB - RAM: 64 MiB - Wireless No1: SoC-integrated: MT7620A 2.4GHz 802.11bgn - Wireless No2: On-board chip: MT7610EN 5GHz 802.11ac - Switch: RTL8367RB Gigabit Switch - USB: Yes 1 x 2.0 Preparing a TFTP recovery image for initial flashing: Currently the only method to install openwrt for the first time is via TFTP download in u-boot. After first install you can use regular updates. WARNING: This method also overwrites the bootloader partition! Create a TFTP recovery image: 1) Download a stock TP-Link Firmware file here: https://www.tp-link.com/en/download/Archer-C2_V1.html#Firmware 2) Extract u-boot from the binary file: #> dd if=c2v1_stock_firmware.bin of=c2v1_uboot.bin bs=1 skip=512 count=131072 3) Now merge the sysupgrade image and the u-boot into one binary: #> cat c2v1_uboot.bin openwrt-squashfs-sysupgrade.bin > ArcherC2V1_tp_recovery.bin The resulting image can be flashed via TFTP recovery mode. Flash instructions: 1) To flash the recovery image, start a TFTP server from IP address 192.168.0.66 and serve the recovery image named ArcherC2V1_tp_recovery.bin. 2) Connect your device to the LAN port, then press the WPS/Reset button and power it up. Keep pressing the WPS/Reset button for 10 seconds. It will try to download the recovery image and flash it. It can take up to 20-25 minutes to finish. When it reaches 100%, the router will reboot itself. Signed-off-by: Serge Vasilugin <vasilugin@yandex.ru> Signed-off-by: Franz Flasch <franz.flasch@gmx.at>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b6499c8806..325e3104a7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -472,6 +472,18 @@ define Device/tiny-ac
endef
TARGET_DEVICES += tiny-ac
+define Device/tplink_c2-v1
+ $(Device/Archer)
+ DTS := ArcherC2-v1
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0xc7500001
+ TPLINK_HWREV := 50
+ IMAGES += factory.bin
+ DEVICE_TITLE := TP-Link Archer C2 v1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
+endef
+TARGET_DEVICES += tplink_c2-v1
+
define Device/tplink_c20-v1
$(Device/Archer)
DTS := ArcherC20v1